Attention is currently required from: Andrey Petrov, Arthur Heymans, Julius Werner, Karthik Ramasubramanian, Nick Vaccaro, Subrata Banik, Yu-Ping Wu.
Tim Van Patten has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/77796?usp=email )
Change subject: {commonlib, libpayload}: Add "has_external display" in coreboot table
......................................................................
Patch Set 5:
(2 comments)
File payloads/libpayload/include/coreboot_tables.h:
https://review.coreboot.org/c/coreboot/+/77796/comment/a903f448_07b17b08 :
PS5, Line 224: uint8_t
Should these be `u8` as well, to be consistent with the other structs in this file?
https://review.coreboot.org/c/coreboot/+/77796/comment/9a6a44ac_36730dd1 :
PS5, Line 246: struct cb_framebuffer_flags flags;
Similar to `lb_framebuffer`, I suggest adding a `u8` padding here as well, to make it clearer where the next field should go to prevent any holes in this struct.
--
To view, visit https://review.coreboot.org/c/coreboot/+/77796?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: I0fa7eee4c5a50371a7a66c6ca1ac2c7d046d010b
Gerrit-Change-Number: 77796
Gerrit-PatchSet: 5
Gerrit-Owner: Subrata Banik <subratabanik(a)google.com>
Gerrit-Reviewer: Andrey Petrov <andrey.petrov(a)gmail.com>
Gerrit-Reviewer: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Reviewer: Julius Werner <jwerner(a)chromium.org>
Gerrit-Reviewer: Nick Vaccaro <nvaccaro(a)chromium.org>
Gerrit-Reviewer: Yu-Ping Wu <yupingso(a)google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Karthik Ramasubramanian <kramasub(a)google.com>
Gerrit-CC: Tim Van Patten <timvp(a)google.com>
Gerrit-Attention: Subrata Banik <subratabanik(a)google.com>
Gerrit-Attention: Nick Vaccaro <nvaccaro(a)chromium.org>
Gerrit-Attention: Julius Werner <jwerner(a)chromium.org>
Gerrit-Attention: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Attention: Andrey Petrov <andrey.petrov(a)gmail.com>
Gerrit-Attention: Yu-Ping Wu <yupingso(a)google.com>
Gerrit-Attention: Karthik Ramasubramanian <kramasub(a)google.com>
Gerrit-Comment-Date: Tue, 03 Oct 2023 16:44:40 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
Attention is currently required from: Kyösti Mälkki, Paul Menzel.
Patrick Rudolph has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/78194?usp=email )
Change subject: cpu/intel/model_206ax: Only use supported C-states
......................................................................
Patch Set 3:
(2 comments)
File src/cpu/intel/model_206ax/acpi.c:
https://review.coreboot.org/c/coreboot/+/78194/comment/0b6e3864_1382529c :
PS2, Line 106: acpi_cstate_map[count].ctype = i + 1;
> I don't see the .ctype field filled anymore.
Good catch.
Fixed.
https://review.coreboot.org/c/coreboot/+/78194/comment/020ca888_3ec0689f :
PS2, Line 97: uint8_t h, l;
> state, substate ? If you changed the previous function on Felix's request.
Done
--
To view, visit https://review.coreboot.org/c/coreboot/+/78194?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: Iaaee050e0ce3c29c12e97f5819a29f485a7946c2
Gerrit-Change-Number: 78194
Gerrit-PatchSet: 3
Gerrit-Owner: Patrick Rudolph <patrick.rudolph(a)9elements.com>
Gerrit-Reviewer: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Kyösti Mälkki <kyosti.malkki(a)gmail.com>
Gerrit-Attention: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Kyösti Mälkki <kyosti.malkki(a)gmail.com>
Gerrit-Comment-Date: Tue, 03 Oct 2023 16:44:14 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Kyösti Mälkki <kyosti.malkki(a)gmail.com>
Gerrit-MessageType: comment
Attention is currently required from: Felix Held, Kyösti Mälkki.
Patrick Rudolph has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/78133?usp=email )
Change subject: cpu/intel/model_206ax: Print supported C-states
......................................................................
Patch Set 6:
(7 comments)
File src/arch/x86/cpu_common.c:
https://review.coreboot.org/c/coreboot/+/78133/comment/74904756_29946a39 :
PS5, Line 196: int cpu_get_c_state_support(const int lvl)
> Is the input parameter 'lvl' really a 'state'. […]
Moved to separate commit.
https://review.coreboot.org/c/coreboot/+/78133/comment/1f384839_f762b51e :
PS5, Line 201: 1
> might be good to have a define for this bit
Done
File src/cpu/intel/model_206ax/acpi.c:
https://review.coreboot.org/c/coreboot/+/78133/comment/d1f78068_cbe5f1eb :
PS5, Line 103: h, l
> it would make the code easier to read if you'd use 'state' and 'substate' as variable names
Done
https://review.coreboot.org/c/coreboot/+/78133/comment/d6b6a6b2_6bd18fa9 :
PS5, Line 104:
> maybe add a comment that C0 is always supported; was wondering why i was initialized as 1, but that […]
yes, added a comment to clarify.
https://review.coreboot.org/c/coreboot/+/78133/comment/8132fb79_55fde0dc :
PS5, Line 109: > l
> i'd drop this or make it != 0 and drop the + 1 in line 106 too; at least for me that would make the […]
That would not result in the same behaviour. cpu_get_c_state_support doesn't return a boolean, but an integer of supported sub-levels. Also the ACPI resource holds a C state starting at C1, so +1 must be added to get the correct CPU C-state.
https://review.coreboot.org/c/coreboot/+/78133/comment/8ad8f63c_37e22b37 :
PS5, Line 110: strcpy(&str[strlen(str)], c_state_names[i]);
: strcpy(&str[strlen(str)], " ");
> i'd just use printk directly instead of assembling a string and then printing it. […]
I ported the code from MPinit, which runs in parallel and made a mess when using printk, but here it's fine.
https://review.coreboot.org/c/coreboot/+/78133/comment/de684a05_dc51bc55 :
PS5, Line 128: print_supported_cstates();
> While there is a call to cpu_get_c_state_support() with cpuid() calls, ACPI table creation only runs […]
Sounds good. Will do on the next push.
--
To view, visit https://review.coreboot.org/c/coreboot/+/78133?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: I713712a1a104714cbf3091782e564e7e784cf21d
Gerrit-Change-Number: 78133
Gerrit-PatchSet: 6
Gerrit-Owner: Patrick Rudolph <patrick.rudolph(a)9elements.com>
Gerrit-Reviewer: Kyösti Mälkki <kyosti.malkki(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Attention: Kyösti Mälkki <kyosti.malkki(a)gmail.com>
Gerrit-Attention: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Comment-Date: Tue, 03 Oct 2023 16:43:54 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Kyösti Mälkki <kyosti.malkki(a)gmail.com>
Comment-In-Reply-To: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-MessageType: comment
Attention is currently required from: Bernardo Perez Priego, Cliff Huang, Eran Mitrani, Jakub Czapiga, Kapil Porwal, Li1 Feng, Subrata Banik, Tarun.
Hello Cliff Huang, Eran Mitrani, Jakub Czapiga, Kapil Porwal, Li1 Feng, Subrata Banik, Tarun, build bot (Jenkins),
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/coreboot/+/78049?usp=email
to look at the new patch set (#4).
The following approvals got outdated and were removed:
Code-Review+1 by Bernardo Perez Priego, Code-Review+1 by Li1 Feng, Code-Review+2 by Subrata Banik, Verified+1 by build bot (Jenkins)
The change is no longer submittable: Code-Review and Verified are unsatisfied now.
Change subject: mb/google/rex: Configure ISH UART TX/RX as NC
......................................................................
mb/google/rex: Configure ISH UART TX/RX as NC
This patch reverses ISH UART pin configuration to allow ISH to enter
into suspend mode. This UART port is for debugging purposes.
BUG=b:302612549
TEST=On Google/rex platform with ISH enabled, do suspend_stress_test
This test must pass
Signed-off-by: Bernardo Perez Priego <bernardo.perez.priego(a)intel.com>
Change-Id: I8aba45420744a3990e1f9637c3b31ea2e0f78f87
---
M src/mainboard/google/rex/variants/rex0/fw_config.c
1 file changed, 0 insertions(+), 4 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/49/78049/4
--
To view, visit https://review.coreboot.org/c/coreboot/+/78049?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: I8aba45420744a3990e1f9637c3b31ea2e0f78f87
Gerrit-Change-Number: 78049
Gerrit-PatchSet: 4
Gerrit-Owner: Bernardo Perez Priego <bernardo.perez.priego(a)intel.com>
Gerrit-Reviewer: Bernardo Perez Priego <bernardo.perez.priego(a)intel.com>
Gerrit-Reviewer: Cliff Huang <cliff.huang(a)intel.com>
Gerrit-Reviewer: Eran Mitrani <mitrani(a)google.com>
Gerrit-Reviewer: Jakub Czapiga <czapiga(a)google.com>
Gerrit-Reviewer: Kapil Porwal <kapilporwal(a)google.com>
Gerrit-Reviewer: Li1 Feng <li1.feng(a)intel.com>
Gerrit-Reviewer: Subrata Banik <subratabanik(a)google.com>
Gerrit-Reviewer: Tarun <tstuli(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Tanu Malhotra <tanu.malhotra(a)intel.com>
Gerrit-Attention: Cliff Huang <cliff.huang(a)intel.com>
Gerrit-Attention: Eran Mitrani <mitrani(a)google.com>
Gerrit-Attention: Subrata Banik <subratabanik(a)google.com>
Gerrit-Attention: Jakub Czapiga <czapiga(a)google.com>
Gerrit-Attention: Li1 Feng <li1.feng(a)intel.com>
Gerrit-Attention: Kapil Porwal <kapilporwal(a)google.com>
Gerrit-Attention: Bernardo Perez Priego <bernardo.perez.priego(a)intel.com>
Gerrit-Attention: Tarun <tstuli(a)gmail.com>
Gerrit-MessageType: newpatchset
Patrick Rudolph has uploaded this change for review. ( https://review.coreboot.org/c/coreboot/+/78230?usp=email )
Change subject: sb/intel/bd82x6x/pch: Mark static devices hidden
......................................................................
sb/intel/bd82x6x/pch: Mark static devices hidden
When hiding static devices mark them as hidden so the
PCI enumeration no longer complains about them being
missing.
Test: PCI: Disabled southbridge devices no longer appear in
"Leftover static devices:" log.
Change-Id: Iae70072a85b62a456102190a5f72f4d652ad6d5a
Signed-off-by: Patrick Rudolph <patrick.rudolph(a)9elements.com>
---
M src/southbridge/intel/bd82x6x/pch.c
1 file changed, 4 insertions(+), 0 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/30/78230/1
diff --git a/src/southbridge/intel/bd82x6x/pch.c b/src/southbridge/intel/bd82x6x/pch.c
index c9e66de..b523f63 100644
--- a/src/southbridge/intel/bd82x6x/pch.c
+++ b/src/southbridge/intel/bd82x6x/pch.c
@@ -131,6 +131,10 @@
/* Set bit in function disable register to hide this device */
static void pch_hide_devfn(unsigned int devfn)
{
+ struct device *dev = pcidev_path_on_root(devfn);
+ if (dev)
+ dev->hidden = true;
+
switch (devfn) {
case PCI_DEVFN(20, 0): /* xHCI */
if (pch_silicon_type() == PCH_TYPE_PPT) {
--
To view, visit https://review.coreboot.org/c/coreboot/+/78230?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: Iae70072a85b62a456102190a5f72f4d652ad6d5a
Gerrit-Change-Number: 78230
Gerrit-PatchSet: 1
Gerrit-Owner: Patrick Rudolph <patrick.rudolph(a)9elements.com>
Gerrit-MessageType: newchange
Patrick Rudolph has uploaded this change for review. ( https://review.coreboot.org/c/coreboot/+/78229?usp=email )
Change subject: sb/intel/bd82x6x: Warn about slow PCIe downstream devices
......................................................................
sb/intel/bd82x6x: Warn about slow PCIe downstream devices
Warn when a device took longer than usual to appear.
Use the PDS bit to detect if a root port has a downstream
device connected and warn if enumeration failed.
Test: On Lenovo X220 all PCIe device are visible, thus the
added code path is never taken.
Change-Id: I86b498b89d672b239d9951e116dc3680030666a6
Signed-off-by: Patrick Rudolph <patrick.rudolph(a)9elements.com>
---
M src/southbridge/intel/bd82x6x/pcie.c
1 file changed, 4 insertions(+), 0 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/29/78229/1
diff --git a/src/southbridge/intel/bd82x6x/pcie.c b/src/southbridge/intel/bd82x6x/pcie.c
index 59ef2cb..f1817ba 100644
--- a/src/southbridge/intel/bd82x6x/pcie.c
+++ b/src/southbridge/intel/bd82x6x/pcie.c
@@ -234,6 +234,10 @@
/* Normal PCIe Scan */
pciexp_scan_bridge(dev);
}
+ if ((pci_read_config32(dev, D28Fx_SLSTS) & PDS) &&
+ !dev_is_active_bridge(dev))
+ printk(BIOS_WARNING, "%s: Has a slow downstream device. Enumeration failed.\n",
+ dev_path(dev));
/* Late Power Management init after bridge device enumeration */
pch_pcie_pm_late(dev);
--
To view, visit https://review.coreboot.org/c/coreboot/+/78229?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: I86b498b89d672b239d9951e116dc3680030666a6
Gerrit-Change-Number: 78229
Gerrit-PatchSet: 1
Gerrit-Owner: Patrick Rudolph <patrick.rudolph(a)9elements.com>
Gerrit-MessageType: newchange