Kyösti Mälkki has submitted this change. ( https://review.coreboot.org/c/coreboot/+/58924 )
Change subject: intel/strago: Fix some CHROMEOS guards
......................................................................
intel/strago: Fix some CHROMEOS guards
MAINBOARD_HAS_CHROMEOS always evaluates true for this board.
The commentary about get_write_protect_state() was wrong, it's
currently only called in ramstage.
Change-Id: I0d5f1520a180ae6762c07dca7284894d9cf661b4
Signed-off-by: Kyösti Mälkki <kyosti.malkki(a)gmail.com>
Reviewed-on: https://review.coreboot.org/c/coreboot/+/58924
Tested-by: build bot (Jenkins) <no-reply(a)coreboot.org>
Reviewed-by: Julius Werner <jwerner(a)chromium.org>
---
M src/mainboard/intel/strago/Makefile.inc
M src/mainboard/intel/strago/chromeos.c
2 files changed, 7 insertions(+), 8 deletions(-)
Approvals:
build bot (Jenkins): Verified
Julius Werner: Looks good to me, approved
diff --git a/src/mainboard/intel/strago/Makefile.inc b/src/mainboard/intel/strago/Makefile.inc
index 21ae380..004a6a2 100644
--- a/src/mainboard/intel/strago/Makefile.inc
+++ b/src/mainboard/intel/strago/Makefile.inc
@@ -2,11 +2,11 @@
bootblock-$(CONFIG_ENABLE_BUILTIN_COM1) += com_init.c
-romstage-$(CONFIG_MAINBOARD_HAS_CHROMEOS) += chromeos.c
+ramstage-$(CONFIG_CHROMEOS) += chromeos.c
+romstage-$(CONFIG_CHROMEOS) += chromeos.c
-ramstage-$(CONFIG_MAINBOARD_HAS_CHROMEOS) += chromeos.c
-ramstage-$(CONFIG_MAINBOARD_HAS_CHROMEOS) += ec.c
-ramstage-$(CONFIG_MAINBOARD_HAS_CHROMEOS) += gpio.c
+ramstage-y += ec.c
+ramstage-y += gpio.c
ramstage-y += irqroute.c
ramstage-y += ramstage.c
ramstage-y += w25q64.c
diff --git a/src/mainboard/intel/strago/chromeos.c b/src/mainboard/intel/strago/chromeos.c
index c0ce968..ad23ea1 100644
--- a/src/mainboard/intel/strago/chromeos.c
+++ b/src/mainboard/intel/strago/chromeos.c
@@ -23,14 +23,13 @@
int get_write_protect_state(void)
{
/*
- * The vboot loader queries this function in romstage. The GPIOs have
+ * This function might get queried early in romstage. The GPIOs have
* not been set up yet as that configuration is done in ramstage.
* Configuring this GPIO as input so that there isn't any ambiguity
* in the reading.
*/
-#if ENV_ROMSTAGE
- gpio_input_pullup(WP_GPIO);
-#endif
+ if (ENV_ROMSTAGE_OR_BEFORE)
+ gpio_input_pullup(WP_GPIO);
/* WP is enabled when the pin is reading high. */
return !!gpio_get(WP_GPIO);
4 is the latest approved patch-set.
No files were changed between the latest approved patch-set and the submitted one.
--
To view, visit https://review.coreboot.org/c/coreboot/+/58924
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I0d5f1520a180ae6762c07dca7284894d9cf661b4
Gerrit-Change-Number: 58924
Gerrit-PatchSet: 7
Gerrit-Owner: Kyösti Mälkki <kyosti.malkki(a)gmail.com>
Gerrit-Reviewer: Julius Werner <jwerner(a)chromium.org>
Gerrit-Reviewer: Kyösti Mälkki <kyosti.malkki(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-MessageType: merged
Attention is currently required from: Jason Glenesk, Raul Rangel, Marshall Dawson, Tim Wawrzynczak, Julius Werner, Karthikeyan Ramasubramanian, Felix Held.
Kyösti Mälkki has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/59094 )
Change subject: [WIP,RFC] Clean up spinlocks
......................................................................
Patch Set 2:
(1 comment)
Commit Message:
https://review.coreboot.org/c/coreboot/+/59094/comment/79ac18a2_4be89f85
PS2, Line 14: IMO commit a98d302fe9 x86/smp/spinlock: Disable thread coop when taking spinlock
: is wrong and should be reverted too.
> I think there is a disconnect between spinlock and thread_mutex.
>
> spinlock was made to prevent more than 1 CPU from executing. As you said, yielding here is bad...
>
> thread_mutex was only meant to work with coop multi-threading to guard a resource. It is safe to yield while holding the mutex because a `thread_mutex_lock` will yield if it can't get the lock.
>
> So we have two options:
> 1) Make a multi-cpu aware thread_mutex and replace all spin_locks.
> 2) Disable thread_yield() while holding a spin lock. This can happen one of two ways:
> 1) Provide thread_yield() some mechanism to determine if a spin lock is being held on the BSP.
> 2) Have spin_lock just disable coop-multi-threading.
>
> Honestly, 2.2 is the easiest to grasp. If you want, I will rename `spin_lock` to `spin_lock_disable_coop` and `spin_unlock_enable_coop`.
I am in favor of 1. This can also address the case with lack of udelay() from uart8250mem, since thread_mutex can be made a periodical yield. And I think 2.1 and 2.2 eat the DMA performance for romstage because there are few (none) calls to thread_yield() where console lock is not held.
> > Now I am not going to -2 these threding and spinlock changes. Just understand your DMA performance currently relies on periodic context switches, and you really really should not rely on uart8250mem and printk() to satisfy that.
>
> Right. In my case the DMA controller can perform 64 KiB transactions. Large things like the payload require being armed twice.
>
> I'm not currently dependent on printk to satisfy that requirement. I'm adding more periodic yields to make it more predictable: https://review.coreboot.org/c/coreboot/+/58955
That improves the case for ramstage only. One might say it's really ugly hack to depend on console for the periodical yields() but the next alternative would be to scatter those yields() here and there.
--
To view, visit https://review.coreboot.org/c/coreboot/+/59094
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Iba52febdeee78294f916775ee9ce8a82d6203570
Gerrit-Change-Number: 59094
Gerrit-PatchSet: 2
Gerrit-Owner: Kyösti Mälkki <kyosti.malkki(a)gmail.com>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Reviewer: Julius Werner <jwerner(a)chromium.org>
Gerrit-Reviewer: Karthikeyan Ramasubramanian <kramasub(a)chromium.org>
Gerrit-Reviewer: Marshall Dawson <marshalldawson3rd(a)gmail.com>
Gerrit-Reviewer: Raul Rangel <rrangel(a)chromium.org>
Gerrit-Reviewer: Tim Wawrzynczak <twawrzynczak(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Attention: Raul Rangel <rrangel(a)chromium.org>
Gerrit-Attention: Marshall Dawson <marshalldawson3rd(a)gmail.com>
Gerrit-Attention: Tim Wawrzynczak <twawrzynczak(a)chromium.org>
Gerrit-Attention: Julius Werner <jwerner(a)chromium.org>
Gerrit-Attention: Karthikeyan Ramasubramanian <kramasub(a)chromium.org>
Gerrit-Attention: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Comment-Date: Thu, 11 Nov 2021 06:20:19 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Raul Rangel <rrangel(a)chromium.org>
Comment-In-Reply-To: Kyösti Mälkki <kyosti.malkki(a)gmail.com>
Gerrit-MessageType: comment
Attention is currently required from: Sumeet R Pawnikar, Peter Ou.
David Wu has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/59089 )
Change subject: mb/google/brya/var/kano: Add thermal sensor settings
......................................................................
Patch Set 3:
(1 comment)
File src/mainboard/google/brya/variants/kano/overridetree.cb:
https://review.coreboot.org/c/coreboot/+/59089/comment/28e28af8_70b6f5c5
PS1, Line 63: CHARGER, TEMP_SENSOR_1
> Do you still want to throttle charger for sensor_1 which is mapped to FAN now as per your this code […]
Done. Thanks.
--
To view, visit https://review.coreboot.org/c/coreboot/+/59089
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I0da25f142149f94c83fdf7b2ba2cb8694cddb412
Gerrit-Change-Number: 59089
Gerrit-PatchSet: 3
Gerrit-Owner: David Wu <david_wu(a)quanta.corp-partner.google.com>
Gerrit-Reviewer: Peter Ou <peter.ou(a)quanta.corp-partner.google.com>
Gerrit-Reviewer: Sumeet R Pawnikar <sumeet.r.pawnikar(a)intel.com>
Gerrit-Reviewer: Tim Wawrzynczak <twawrzynczak(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Sumeet R Pawnikar <sumeet.r.pawnikar(a)intel.com>
Gerrit-Attention: Peter Ou <peter.ou(a)quanta.corp-partner.google.com>
Gerrit-Comment-Date: Thu, 11 Nov 2021 06:18:04 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Sumeet R Pawnikar <sumeet.r.pawnikar(a)intel.com>
Gerrit-MessageType: comment
Attention is currently required from: Arthur Heymans, Martin Roth.
Patrick Georgi has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/59133 )
Change subject: Makefile.inc: Add a master header pointer as a regular cbfs file
......................................................................
Patch Set 1:
(1 comment)
Patchset:
PS1:
Who still needs the master header? It's legacy stuff.
libpayload is just about to lose the need, so who else?
--
To view, visit https://review.coreboot.org/c/coreboot/+/59133
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I99b8d4e2b4e9109b239804c86a1911ba916bd966
Gerrit-Change-Number: 59133
Gerrit-PatchSet: 1
Gerrit-Owner: Arthur Heymans <arthur.heymans(a)9elements.com>
Gerrit-Reviewer: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Reviewer: Martin Roth <martinroth(a)google.com>
Gerrit-Reviewer: Patrick Georgi <patrick(a)coreboot.org>
Gerrit-CC: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Arthur Heymans <arthur.heymans(a)9elements.com>
Gerrit-Attention: Martin Roth <martinroth(a)google.com>
Gerrit-Attention: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Comment-Date: Thu, 11 Nov 2021 06:02:54 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
Attention is currently required from: Tim Wawrzynczak, Patrick Rudolph.
Tracy Wu has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/59081 )
Change subject: soc/intel/common/block/pcie: Add ADL-P CPU PCIe Device IDs
......................................................................
Patch Set 2:
(1 comment)
Patchset:
PS2:
> couple questions: […]
Yes, per FSP code and confirmed with our PCIe team, they are the same.
--
To view, visit https://review.coreboot.org/c/coreboot/+/59081
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Idc8a09b0579e1e6053ed2e35b7556a180a5f0088
Gerrit-Change-Number: 59081
Gerrit-PatchSet: 2
Gerrit-Owner: Tracy Wu <tracy.wu(a)intel.corp-partner.google.com>
Gerrit-Reviewer: EricR Lai <ericr_lai(a)compal.corp-partner.google.com>
Gerrit-Reviewer: Kane Chen <kane.chen(a)intel.corp-partner.google.com>
Gerrit-Reviewer: Patrick Rudolph <siro(a)das-labor.org>
Gerrit-Reviewer: Tim Wawrzynczak <twawrzynczak(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Tim Wawrzynczak <twawrzynczak(a)chromium.org>
Gerrit-Attention: Patrick Rudolph <siro(a)das-labor.org>
Gerrit-Comment-Date: Thu, 11 Nov 2021 05:33:21 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Tim Wawrzynczak <twawrzynczak(a)chromium.org>
Gerrit-MessageType: comment
Attention is currently required from: David Wu, Tim Wawrzynczak, Zhuohao Lee.
Alan Huang has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/59086 )
Change subject: drivers/net/r8168: Add support for Realtek RT8125
......................................................................
Patch Set 5:
(1 comment)
Patchset:
PS5:
May I update the LED part in another commit? Verify the commit with correct LED settings?
--
To view, visit https://review.coreboot.org/c/coreboot/+/59086
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Iaa4c41f94fd6e5fd6393abbb30bfc22a149f5d71
Gerrit-Change-Number: 59086
Gerrit-PatchSet: 5
Gerrit-Owner: Alan Huang <alan-huang(a)quanta.corp-partner.google.com>
Gerrit-Reviewer: David Wu <david_wu(a)quanta.corp-partner.google.com>
Gerrit-Reviewer: Tim Wawrzynczak <twawrzynczak(a)chromium.org>
Gerrit-Reviewer: Zhuohao Lee <zhuohao(a)google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: David Wu <david_wu(a)quanta.corp-partner.google.com>
Gerrit-Attention: Tim Wawrzynczak <twawrzynczak(a)chromium.org>
Gerrit-Attention: Zhuohao Lee <zhuohao(a)google.com>
Gerrit-Comment-Date: Thu, 11 Nov 2021 05:06:29 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
Attention is currently required from: David Wu, Tim Wawrzynczak, Zhuohao Lee.
Alan Huang has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/59086 )
Change subject: drivers/net/r8168: Add support for Realtek RT8125
......................................................................
Set Ready For Review
--
To view, visit https://review.coreboot.org/c/coreboot/+/59086
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Iaa4c41f94fd6e5fd6393abbb30bfc22a149f5d71
Gerrit-Change-Number: 59086
Gerrit-PatchSet: 5
Gerrit-Owner: Alan Huang <alan-huang(a)quanta.corp-partner.google.com>
Gerrit-Reviewer: David Wu <david_wu(a)quanta.corp-partner.google.com>
Gerrit-Reviewer: Tim Wawrzynczak <twawrzynczak(a)chromium.org>
Gerrit-Reviewer: Zhuohao Lee <zhuohao(a)google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: David Wu <david_wu(a)quanta.corp-partner.google.com>
Gerrit-Attention: Tim Wawrzynczak <twawrzynczak(a)chromium.org>
Gerrit-Attention: Zhuohao Lee <zhuohao(a)google.com>
Gerrit-Comment-Date: Thu, 11 Nov 2021 05:03:57 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
Attention is currently required from: Sugnan Prabhu S, Paul Menzel, Kane Chen.
Hello build bot (Jenkins), Sugnan Prabhu S, Kane Chen, Kane Chen,
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/coreboot/+/58951
to look at the new patch set (#6).
Change subject: drivers/wifi/generic: fix package_size to align with WLAN driver
......................................................................
drivers/wifi/generic: fix package_size to align with WLAN driver
Change to use MAX_DSAR_SET_COUNT which WLAN driver always expects 3
no matter what the revision is for EWRD.
It will pass the WLAN driver check then to retrieve the data properly.
BUG=b:204414616
TEST= tested on brya with DRTU tool to verify if SAR table is
read properly or not.
Change-Id: I18e7d5f658bbf42b7eeed3da330508f14b86c0f8
Signed-off-by: Matt Chen <matt.chen(a)intel.corp-partner.google.com>
---
M src/drivers/wifi/generic/acpi.c
1 file changed, 1 insertion(+), 1 deletion(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/51/58951/6
--
To view, visit https://review.coreboot.org/c/coreboot/+/58951
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I18e7d5f658bbf42b7eeed3da330508f14b86c0f8
Gerrit-Change-Number: 58951
Gerrit-PatchSet: 6
Gerrit-Owner: Matt Chen <matt.chen(a)intel.corp-partner.google.com>
Gerrit-Reviewer: Kane Chen <kane.chen(a)intel.com>
Gerrit-Reviewer: Kane Chen <kane.chen(a)intel.corp-partner.google.com>
Gerrit-Reviewer: Matt Chen <matt.chen(a)intel.corp-partner.google.com>
Gerrit-Reviewer: Sugnan Prabhu S <sugnan.prabhu.s(a)intel.corp-partner.google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Janiex Tu <janiex.tu(a)intel.corp-partner.google.com>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Sugnan Prabhu S <sugnan.prabhu.s(a)intel.corp-partner.google.com>
Gerrit-Attention: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Kane Chen <kane.chen(a)intel.com>
Gerrit-MessageType: newpatchset
Attention is currently required from: Sugnan Prabhu S, Tim Wawrzynczak, Ravindra, Patrick Rudolph, Ravindra N.
Sridhar Siricilla has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/57783 )
Change subject: cpu/intel/common: Update CPPCv3 Nominal Frequency entry
......................................................................
Patch Set 7:
(2 comments)
File src/acpi/acpigen.c:
https://review.coreboot.org/c/coreboot/+/57783/comment/97756513_55bf7fe5
PS4, Line 1799: printk(BIOS_DEBUG, "config->regs[0].addrl= %d, config->regs[0].addrh= %d\n",
: config->regs[0].addrl, config->regs[0].addrh);
> added for debug purpose
Done
File src/acpi/acpigen.c:
https://review.coreboot.org/c/coreboot/+/57783/comment/efdca1e9_3eb8999e
PS5, Line 1781: switch (config->version) {
> > switch and case should be at the same indent […]
Done
--
To view, visit https://review.coreboot.org/c/coreboot/+/57783
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: If39e5e4ac77a71b143cdb5f043fb398abb398ee3
Gerrit-Change-Number: 57783
Gerrit-PatchSet: 7
Gerrit-Owner: Ravindra <ravindra(a)intel.com>
Gerrit-Reviewer: Patrick Rudolph <siro(a)das-labor.org>
Gerrit-Reviewer: Sridhar Siricilla <sridhar.siricilla(a)intel.com>
Gerrit-Reviewer: Sugnan Prabhu S <sugnan.prabhu.s(a)intel.com>
Gerrit-Reviewer: Tim Wawrzynczak <twawrzynczak(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Maulik V Vaghela <maulik.v.vaghela(a)intel.com>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-CC: Ravindra N <ravindra(a)intel.corp-partner.google.com>
Gerrit-CC: Subrata Banik <subrata.banik(a)intel.com>
Gerrit-Attention: Sugnan Prabhu S <sugnan.prabhu.s(a)intel.com>
Gerrit-Attention: Tim Wawrzynczak <twawrzynczak(a)chromium.org>
Gerrit-Attention: Ravindra <ravindra(a)intel.com>
Gerrit-Attention: Patrick Rudolph <siro(a)das-labor.org>
Gerrit-Attention: Ravindra N <ravindra(a)intel.corp-partner.google.com>
Gerrit-Comment-Date: Thu, 11 Nov 2021 04:41:54 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Sridhar Siricilla <sridhar.siricilla(a)intel.com>
Comment-In-Reply-To: Ravindra N <ravindra(a)intel.corp-partner.google.com>
Gerrit-MessageType: comment