Attention is currently required from: Arthur Heymans, Nico Huber.
Hello build bot (Jenkins), Nico Huber, Angel Pons, Arthur Heymans,
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/coreboot/+/59131
to look at the new patch set (#4).
Change subject: device/pci_device.c: Improve pci_bridge_route() readability
......................................................................
device/pci_device.c: Improve pci_bridge_route() readability
Both the secondary and subordinate bus numbers are configured in this
function but it's not easy to search for in the tree as the PCI writes
are hidden inside a bigger write to 'PCI_PRIMARY_BUS'. Use separate
variables and PCI config writes to improve the readability.
Change-Id: I3bafd6a2e1d3a0b8d1d43997868a787ce3940ca9
Signed-off-by: Arthur Heymans <arthur(a)aheymans.xyz>
---
M src/device/pci_device.c
1 file changed, 14 insertions(+), 13 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/31/59131/4
--
To view, visit https://review.coreboot.org/c/coreboot/+/59131
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I3bafd6a2e1d3a0b8d1d43997868a787ce3940ca9
Gerrit-Change-Number: 59131
Gerrit-PatchSet: 4
Gerrit-Owner: Arthur Heymans <arthur.heymans(a)9elements.com>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Attention: Arthur Heymans <arthur.heymans(a)9elements.com>
Gerrit-Attention: Nico Huber <nico.h(a)gmx.de>
Gerrit-MessageType: newpatchset
Attention is currently required from: Andrey Pronin, Raul Rangel, Julius Werner, Yu-Ping Wu.
Karthik Ramasubramanian has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/59476 )
Change subject: src/security/vboot: Setup secure counter space in TPM NVRAM
......................................................................
Patch Set 1:
(1 comment)
File src/security/vboot/secdata_tpm.c:
https://review.coreboot.org/c/coreboot/+/59476/comment/a20c42f1_3d718fa4
PS1, Line 368: rv = tlcl_read(index, &value, SECURE_COUNTER_SIZE);
> Oh okay, sorry, I should read things more closely before I talk like I knew things. […]
Yes, increment operation can be done in the first use. Trusted application in PSP has agreed and in fact preferred to do that. So I can remove the read + increment operations here and just define the space.
--
To view, visit https://review.coreboot.org/c/coreboot/+/59476
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I915fbdada60e242d911b748ad5dc28028de9b657
Gerrit-Change-Number: 59476
Gerrit-PatchSet: 1
Gerrit-Owner: Karthik Ramasubramanian <kramasub(a)google.com>
Gerrit-Reviewer: Andrey Pronin <apronin(a)google.com>
Gerrit-Reviewer: Julius Werner <jwerner(a)chromium.org>
Gerrit-Reviewer: Raul Rangel <rrangel(a)chromium.org>
Gerrit-Reviewer: Yu-Ping Wu <yupingso(a)google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Andrey Pronin <apronin(a)chromium.org>
Gerrit-Attention: Andrey Pronin <apronin(a)google.com>
Gerrit-Attention: Andrey Pronin <apronin(a)chromium.org>
Gerrit-Attention: Raul Rangel <rrangel(a)chromium.org>
Gerrit-Attention: Julius Werner <jwerner(a)chromium.org>
Gerrit-Attention: Yu-Ping Wu <yupingso(a)google.com>
Gerrit-Comment-Date: Fri, 19 Nov 2021 17:18:01 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Andrey Pronin <apronin(a)chromium.org>
Comment-In-Reply-To: Julius Werner <jwerner(a)chromium.org>
Comment-In-Reply-To: Karthik Ramasubramanian <kramasub(a)google.com>
Gerrit-MessageType: comment
Attention is currently required from: Andrey Pronin, Raul Rangel, Yu-Ping Wu, Karthik Ramasubramanian.
Julius Werner has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/59476 )
Change subject: src/security/vboot: Setup secure counter space in TPM NVRAM
......................................................................
Patch Set 1:
(1 comment)
File src/security/vboot/secdata_tpm.c:
https://review.coreboot.org/c/coreboot/+/59476/comment/56fa1597_afa867cd
PS1, Line 368: rv = tlcl_read(index, &value, SECURE_COUNTER_SIZE);
> wait, we actually do something: https://review.coreboot.org/c/coreboot/+/23456/ […]
Oh okay, sorry, I should read things more closely before I talk like I knew things. But like you said, looks like that should also already work for this case without requiring extra logic.
As for the increment, I would prefer if we could just leave it out here to keep firmware code simpler (see comment on line 355). Can't we just do that on first use in userspace?
--
To view, visit https://review.coreboot.org/c/coreboot/+/59476
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I915fbdada60e242d911b748ad5dc28028de9b657
Gerrit-Change-Number: 59476
Gerrit-PatchSet: 1
Gerrit-Owner: Karthik Ramasubramanian <kramasub(a)google.com>
Gerrit-Reviewer: Andrey Pronin <apronin(a)google.com>
Gerrit-Reviewer: Julius Werner <jwerner(a)chromium.org>
Gerrit-Reviewer: Raul Rangel <rrangel(a)chromium.org>
Gerrit-Reviewer: Yu-Ping Wu <yupingso(a)google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Andrey Pronin <apronin(a)chromium.org>
Gerrit-Attention: Andrey Pronin <apronin(a)google.com>
Gerrit-Attention: Andrey Pronin <apronin(a)chromium.org>
Gerrit-Attention: Raul Rangel <rrangel(a)chromium.org>
Gerrit-Attention: Yu-Ping Wu <yupingso(a)google.com>
Gerrit-Attention: Karthik Ramasubramanian <kramasub(a)google.com>
Gerrit-Comment-Date: Fri, 19 Nov 2021 17:15:28 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Andrey Pronin <apronin(a)chromium.org>
Comment-In-Reply-To: Julius Werner <jwerner(a)chromium.org>
Comment-In-Reply-To: Karthik Ramasubramanian <kramasub(a)google.com>
Gerrit-MessageType: comment
Attention is currently required from: Felix Singer, Sean Rhodes, SRIDHAR SIRICILLA, Furquan Shaikh, Paul Menzel, Rizwan Qureshi, Subrata Banik, Sridhar Siricilla, Arthur Heymans, Evgeny Zinoviev, Patrick Rudolph, Felix Held.
Tim Wawrzynczak has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/52800 )
Change subject: soc/intel: Allow enable/disable ME via CMOS
......................................................................
Patch Set 91: Code-Review+2
(1 comment)
Patchset:
PS91:
Thanks for your patience, Sean, I know you've been working on this one for a long time 😊
--
To view, visit https://review.coreboot.org/c/coreboot/+/52800
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I374db3b7c0ded71cdc18f27970252fec7220cc20
Gerrit-Change-Number: 52800
Gerrit-PatchSet: 91
Gerrit-Owner: Sean Rhodes <admin(a)starlabs.systems>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Evgeny Zinoviev <me(a)ch1p.io>
Gerrit-Reviewer: Furquan Shaikh <furquan.m.shaikh(a)gmail.com>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: Patrick Rudolph <siro(a)das-labor.org>
Gerrit-Reviewer: Rizwan Qureshi <rizwan.qureshi(a)intel.com>
Gerrit-Reviewer: SRIDHAR SIRICILLA
Gerrit-Reviewer: Sridhar Siricilla <sridhar.siricilla(a)intel.com>
Gerrit-Reviewer: Subrata Banik <subrata.banik(a)intel.com>
Gerrit-Reviewer: Tim Crawford <tcrawford(a)system76.com>
Gerrit-Reviewer: Tim Wawrzynczak <twawrzynczak(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Felix Singer <felixsinger(a)posteo.net>
Gerrit-CC: Andy Pont <andy.pont(a)sdcsystems.com>
Gerrit-CC: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-CC: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Attention: Sean Rhodes <admin(a)starlabs.systems>
Gerrit-Attention: SRIDHAR SIRICILLA
Gerrit-Attention: Furquan Shaikh <furquan.m.shaikh(a)gmail.com>
Gerrit-Attention: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Rizwan Qureshi <rizwan.qureshi(a)intel.com>
Gerrit-Attention: Subrata Banik <subrata.banik(a)intel.com>
Gerrit-Attention: Sridhar Siricilla <sridhar.siricilla(a)intel.com>
Gerrit-Attention: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Attention: Evgeny Zinoviev <me(a)ch1p.io>
Gerrit-Attention: Patrick Rudolph <siro(a)das-labor.org>
Gerrit-Attention: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Comment-Date: Fri, 19 Nov 2021 17:13:38 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment
Attention is currently required from: Varshit B Pandya.
Tim Wawrzynczak has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/59260 )
Change subject: mb/google/brya/var/redrix: Configure _DSC for CAM devices to ACPI_DEVICE_SLEEP_D3_COLD
......................................................................
Patch Set 3: Code-Review+2
(1 comment)
File src/mainboard/google/brya/variants/redrix/overridetree.cb:
https://review.coreboot.org/c/coreboot/+/59260/comment/5906034c_6ffb3b72
PS3, Line 355: GPP_D16
Not for this change, but we need to improve this driver... two different power resources are both exposing GPP_D16, which could cause races or other undesirable power states 😞
--
To view, visit https://review.coreboot.org/c/coreboot/+/59260
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I88ea1b87698c63e1bd69367ee857fba3f25c84ea
Gerrit-Change-Number: 59260
Gerrit-PatchSet: 3
Gerrit-Owner: Varshit B Pandya <varshit.b.pandya(a)intel.com>
Gerrit-Reviewer: Chen Wisley <wisley.chen(a)quantatw.com>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Tim Wawrzynczak <twawrzynczak(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: 9elements QA <hardwaretestrobot(a)gmail.com>
Gerrit-CC: Arec <arec.kao(a)intel.com>
Gerrit-CC: Rizwan Qureshi <rizwan.qureshi(a)intel.com>
Gerrit-Attention: Varshit B Pandya <varshit.b.pandya(a)intel.com>
Gerrit-Comment-Date: Fri, 19 Nov 2021 17:07:50 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment
Attention is currently required from: Arthur Heymans, Raul Rangel, Tristan Corrick, Alexander Couzens, Patrick Rudolph.
Angel Pons has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/59314 )
Change subject: cpu/haswell/*.c: Use static.c exposed lapic 0
......................................................................
Patch Set 2:
(1 comment)
File src/mainboard/google/auron/devicetree.cb:
https://review.coreboot.org/c/coreboot/+/59314/comment/6dd86287_86a0adab
PS2, Line 20: device lapic 0xacac off end
> Just thinking out loud. […]
This devicetree structure wouldn't work because the CPU cluster device is used to do MP init. `src/soc/intel/broadwell/northbridge.c` function `broadwell_enable()` assigns the ops for the domain and cpu_cluster devices.
Granted, you could do this in the CPU chip, but you would then have two isolated chips in the devicetree, which doesn't make sense. It would no longer be a device tree!
In any case, I have no idea who decided to do it this way, nor why they chose this approach.
--
To view, visit https://review.coreboot.org/c/coreboot/+/59314
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Ic449b2df8036e8c02b5559cca6b2e7479a70a786
Gerrit-Change-Number: 59314
Gerrit-PatchSet: 2
Gerrit-Owner: Arthur Heymans <arthur.heymans(a)9elements.com>
Gerrit-Reviewer: Alexander Couzens <lynxis(a)fe80.eu>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Patrick Rudolph <siro(a)das-labor.org>
Gerrit-Reviewer: Raul Rangel <rrangel(a)chromium.org>
Gerrit-Reviewer: Tristan Corrick <tristan(a)corrick.kiwi>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Attention: Arthur Heymans <arthur.heymans(a)9elements.com>
Gerrit-Attention: Raul Rangel <rrangel(a)chromium.org>
Gerrit-Attention: Tristan Corrick <tristan(a)corrick.kiwi>
Gerrit-Attention: Alexander Couzens <lynxis(a)fe80.eu>
Gerrit-Attention: Patrick Rudolph <siro(a)das-labor.org>
Gerrit-Comment-Date: Fri, 19 Nov 2021 17:05:21 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Raul Rangel <rrangel(a)chromium.org>
Gerrit-MessageType: comment
Attention is currently required from: Arthur Heymans, Tristan Corrick, Angel Pons, Alexander Couzens, Patrick Rudolph.
Raul Rangel has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/59314 )
Change subject: cpu/haswell/*.c: Use static.c exposed lapic 0
......................................................................
Patch Set 2:
(1 comment)
File src/mainboard/google/auron/devicetree.cb:
https://review.coreboot.org/c/coreboot/+/59314/comment/0bd0f79c_1049b7c2
PS2, Line 20: device lapic 0xacac off end
> Going back to my original question. Why do we need the lapic to hold the config? […]
Just thinking out loud. I suspect that once cpu_cluster has the chip_info, each cpu should be able to get the config via `cpu_dev->parent->chip_info`.
--
To view, visit https://review.coreboot.org/c/coreboot/+/59314
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Ic449b2df8036e8c02b5559cca6b2e7479a70a786
Gerrit-Change-Number: 59314
Gerrit-PatchSet: 2
Gerrit-Owner: Arthur Heymans <arthur.heymans(a)9elements.com>
Gerrit-Reviewer: Alexander Couzens <lynxis(a)fe80.eu>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Patrick Rudolph <siro(a)das-labor.org>
Gerrit-Reviewer: Raul Rangel <rrangel(a)chromium.org>
Gerrit-Reviewer: Tristan Corrick <tristan(a)corrick.kiwi>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Attention: Arthur Heymans <arthur.heymans(a)9elements.com>
Gerrit-Attention: Tristan Corrick <tristan(a)corrick.kiwi>
Gerrit-Attention: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Attention: Alexander Couzens <lynxis(a)fe80.eu>
Gerrit-Attention: Patrick Rudolph <siro(a)das-labor.org>
Gerrit-Comment-Date: Fri, 19 Nov 2021 16:52:54 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Raul Rangel <rrangel(a)chromium.org>
Gerrit-MessageType: comment
Attention is currently required from: Ben Chuang.
Tim Wawrzynczak has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/59429 )
Change subject: drivers/genesyslogic/gl9750: Add driver for Genesys Logic GL9750
......................................................................
Patch Set 1:
(3 comments)
Commit Message:
https://review.coreboot.org/c/coreboot/+/59429/comment/f067f977_6d9b9717
PS1, Line 14:
could you add
`BUG=b:206014046`
here?
Patchset:
PS1:
> Hi Tim, this patch is similar to CL#57632 | https://review.coreboot.org/c/coreboot/+/57632. […]
Thanks Ben, looks like we have b:206014046 for this
File src/drivers/genesyslogic/gl9750/gl9750.c:
https://review.coreboot.org/c/coreboot/+/59429/comment/da849708_dc61bcfa
PS1, Line 7: #include <device/path.h>
unused?
--
To view, visit https://review.coreboot.org/c/coreboot/+/59429
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I6d60cef41baade7457a159d3ce2f8d2e6b66e71c
Gerrit-Change-Number: 59429
Gerrit-PatchSet: 1
Gerrit-Owner: Ben Chuang <benchuanggli(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Greg Tu <greg.tu(a)genesyslogic.com.tw>
Gerrit-CC: HsuanYang Chen <ynop77(a)gmail.com>
Gerrit-CC: Tim Wawrzynczak <twawrzynczak(a)chromium.org>
Gerrit-Attention: Ben Chuang <benchuanggli(a)gmail.com>
Gerrit-Comment-Date: Fri, 19 Nov 2021 16:40:20 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Ben Chuang <benchuanggli(a)gmail.com>
Comment-In-Reply-To: Tim Wawrzynczak <twawrzynczak(a)chromium.org>
Gerrit-MessageType: comment