Subrata Banik has uploaded a new patch set (#13) to the change originally created by Sridhar Siricilla. ( https://review.coreboot.org/c/coreboot/+/46899 )
Change subject: mb/intel/adlrvp: Add support for LPDDR5
......................................................................
mb/intel/adlrvp: Add support for LPDDR5
This patch adds LPDDR5 memory configuration parameters to FSP.
TEST=Able to pass FSP-M MRC training on LPDDR5 RVP.
Signed-off-by: Sridhar Siricilla <sridhar.siricilla(a)intel.com>
Change-Id: I787bf97dd6c244bd3b0662e5bd061a2da80baa90
---
M src/mainboard/intel/adlrvp/include/baseboard/variants.h
M src/mainboard/intel/adlrvp/memory.c
M src/mainboard/intel/adlrvp/romstage_fsp_params.c
M src/mainboard/intel/adlrvp/spd/Makefile.inc
A src/mainboard/intel/adlrvp/spd/adlrvp_lp5.spd.hex
5 files changed, 71 insertions(+), 4 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/99/46899/13
--
To view, visit https://review.coreboot.org/c/coreboot/+/46899
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I787bf97dd6c244bd3b0662e5bd061a2da80baa90
Gerrit-Change-Number: 46899
Gerrit-PatchSet: 13
Gerrit-Owner: Sridhar Siricilla <sridhar.siricilla(a)intel.com>
Gerrit-Reviewer: Aamir Bohra <aamir.bohra(a)intel.com>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Balaji Manigandan <balaji.bmg(a)gmail.com>
Gerrit-Reviewer: Balaji Manigandan <balaji.manigandan(a)intel.com>
Gerrit-Reviewer: Furquan Shaikh <furquan(a)google.com>
Gerrit-Reviewer: Martin Roth <martinroth(a)google.com>
Gerrit-Reviewer: Meera Ravindranath <meera.ravindranath(a)intel.com>
Gerrit-Reviewer: Patrick Georgi <pgeorgi(a)google.com>
Gerrit-Reviewer: Rizwan Qureshi <rizwan.qureshi(a)intel.com>
Gerrit-Reviewer: Subrata Banik <subrata.banik(a)intel.com>
Gerrit-Reviewer: Sugnan Prabhu S <sugnan.prabhu.s(a)intel.com>
Gerrit-Reviewer: Tim Wawrzynczak <twawrzynczak(a)chromium.org>
Gerrit-Reviewer: V Sowmya <v.sowmya(a)intel.com>
Gerrit-Reviewer: Varshit B Pandya <varshit.b.pandya(a)intel.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Maulik V Vaghela <maulik.v.vaghela(a)intel.com>
Gerrit-CC: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-MessageType: newpatchset
Subrata Banik has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/46899 )
Change subject: mb/intel/adlp: Add support for LPDDR5
......................................................................
Patch Set 12:
(1 comment)
https://review.coreboot.org/c/coreboot/+/46899/12/src/mainboard/intel/adlrv…
File src/mainboard/intel/adlrvp/memory.c:
https://review.coreboot.org/c/coreboot/+/46899/12/src/mainboard/intel/adlrv…
PS12, Line 62: 15, 14, 12, 13, 8, 9, 10, 11 }, /* Byte 1 */
> I’d also remove the comments.
>
> For the record (for myself), it’s an array:
>
> uint8_t dq_map[DDR_NUM_CHANNELS][BYTES_PER_CHANNEL * BITS_PER_BYTE];
yes, Paul its an array.
we could put 0 and 1 in same line, its more about readability in code
--
To view, visit https://review.coreboot.org/c/coreboot/+/46899
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I787bf97dd6c244bd3b0662e5bd061a2da80baa90
Gerrit-Change-Number: 46899
Gerrit-PatchSet: 12
Gerrit-Owner: Sridhar Siricilla <sridhar.siricilla(a)intel.com>
Gerrit-Reviewer: Aamir Bohra <aamir.bohra(a)intel.com>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Balaji Manigandan <balaji.bmg(a)gmail.com>
Gerrit-Reviewer: Balaji Manigandan <balaji.manigandan(a)intel.com>
Gerrit-Reviewer: Furquan Shaikh <furquan(a)google.com>
Gerrit-Reviewer: Martin Roth <martinroth(a)google.com>
Gerrit-Reviewer: Meera Ravindranath <meera.ravindranath(a)intel.com>
Gerrit-Reviewer: Patrick Georgi <pgeorgi(a)google.com>
Gerrit-Reviewer: Rizwan Qureshi <rizwan.qureshi(a)intel.com>
Gerrit-Reviewer: Subrata Banik <subrata.banik(a)intel.com>
Gerrit-Reviewer: Sugnan Prabhu S <sugnan.prabhu.s(a)intel.com>
Gerrit-Reviewer: Tim Wawrzynczak <twawrzynczak(a)chromium.org>
Gerrit-Reviewer: V Sowmya <v.sowmya(a)intel.com>
Gerrit-Reviewer: Varshit B Pandya <varshit.b.pandya(a)intel.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Maulik V Vaghela <maulik.v.vaghela(a)intel.com>
Gerrit-CC: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-Comment-Date: Thu, 26 Nov 2020 13:48:54 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-MessageType: comment
Paul Menzel has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/46899 )
Change subject: mb/intel/adlp: Add support for LPDDR5
......................................................................
Patch Set 12:
(1 comment)
https://review.coreboot.org/c/coreboot/+/46899/12/src/mainboard/intel/adlrv…
File src/mainboard/intel/adlrvp/memory.c:
https://review.coreboot.org/c/coreboot/+/46899/12/src/mainboard/intel/adlrv…
PS12, Line 62: 15, 14, 12, 13, 8, 9, 10, 11 }, /* Byte 1 */
> Should bytes 0 and 1 be put on one line?
I’d also remove the comments.
For the record (for myself), it’s an array:
uint8_t dq_map[DDR_NUM_CHANNELS][BYTES_PER_CHANNEL * BITS_PER_BYTE];
--
To view, visit https://review.coreboot.org/c/coreboot/+/46899
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I787bf97dd6c244bd3b0662e5bd061a2da80baa90
Gerrit-Change-Number: 46899
Gerrit-PatchSet: 12
Gerrit-Owner: Sridhar Siricilla <sridhar.siricilla(a)intel.com>
Gerrit-Reviewer: Aamir Bohra <aamir.bohra(a)intel.com>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Balaji Manigandan <balaji.bmg(a)gmail.com>
Gerrit-Reviewer: Balaji Manigandan <balaji.manigandan(a)intel.com>
Gerrit-Reviewer: Furquan Shaikh <furquan(a)google.com>
Gerrit-Reviewer: Martin Roth <martinroth(a)google.com>
Gerrit-Reviewer: Meera Ravindranath <meera.ravindranath(a)intel.com>
Gerrit-Reviewer: Patrick Georgi <pgeorgi(a)google.com>
Gerrit-Reviewer: Rizwan Qureshi <rizwan.qureshi(a)intel.com>
Gerrit-Reviewer: Subrata Banik <subrata.banik(a)intel.com>
Gerrit-Reviewer: Sugnan Prabhu S <sugnan.prabhu.s(a)intel.com>
Gerrit-Reviewer: Tim Wawrzynczak <twawrzynczak(a)chromium.org>
Gerrit-Reviewer: V Sowmya <v.sowmya(a)intel.com>
Gerrit-Reviewer: Varshit B Pandya <varshit.b.pandya(a)intel.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Maulik V Vaghela <maulik.v.vaghela(a)intel.com>
Gerrit-CC: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-Comment-Date: Thu, 26 Nov 2020 13:31:57 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-MessageType: comment
Arthur Heymans has uploaded this change for review. ( https://review.coreboot.org/c/coreboot/+/47193 )
Change subject: arch/x86: Remove 64KiB bootblock limit
......................................................................
arch/x86: Remove 64KiB bootblock limit
X86 CPU start by executing the reset vector in 16bit real mode. The
first instruction, called the reset vector is a jump instruction.
Since this is 16bit the jump needs to remain in the 64KiB section.
This adds a section to the linker script for code that needs to remain
close enough to the reset vector. As soon as we are in 32bit protected
mode we can jump anywhere else in the bootblock. This removes the
64KiB limit on the C_ENV_BOOTBLOCK_SIZE.
For systems where the SIPI vector is in ROM the alignment of the
_start16bit symbol is handled in the linker script instead of the
assembly code.
Change-Id: I192fd08311fccf2e73a70799de2b028a9c8c4a40
Signed-off-by: Arthur Heymans <arthur(a)aheymans.xyz>
---
M src/arch/x86/bootblock_crt0.S
M src/cpu/x86/16bit/entry16.inc
M src/cpu/x86/16bit/reset16.ld
3 files changed, 27 insertions(+), 3 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/93/47193/1
diff --git a/src/arch/x86/bootblock_crt0.S b/src/arch/x86/bootblock_crt0.S
index 3f41464..389dd55 100644
--- a/src/arch/x86/bootblock_crt0.S
+++ b/src/arch/x86/bootblock_crt0.S
@@ -10,16 +10,18 @@
#include <cpu/x86/cr.h>
-.section .text
-
/*
* Include the old code for reset vector and protected mode entry. That code has
* withstood the test of time.
*/
+.section ".bootblock.top", "ax", @progbits
#include <cpu/x86/16bit/entry16.inc>
#include <cpu/x86/16bit/reset16.inc>
#include <cpu/x86/32bit/entry32.inc>
+ jmp continue_text
+.section .text
+continue_text:
#if CONFIG(BOOTBLOCK_DEBUG_SPINLOOP)
/* Wait for a JTAG debugger to break in and set EBX non-zero */
diff --git a/src/cpu/x86/16bit/entry16.inc b/src/cpu/x86/16bit/entry16.inc
index 13d12be..86c14a0 100644
--- a/src/cpu/x86/16bit/entry16.inc
+++ b/src/cpu/x86/16bit/entry16.inc
@@ -31,7 +31,6 @@
/* Symbol _start16bit must be aligned to 4kB to start AP CPUs with
* Startup IPI message without RAM.
*/
-.align 4096
.code16
.globl _start16bit
.type _start16bit, @function
diff --git a/src/cpu/x86/16bit/reset16.ld b/src/cpu/x86/16bit/reset16.ld
index b90dd04..97e70b9 100644
--- a/src/cpu/x86/16bit/reset16.ld
+++ b/src/cpu/x86/16bit/reset16.ld
@@ -2,11 +2,27 @@
/* _RESET_VECTOR: typically the top of the ROM */
+#define ALIGN_DOWN(loc, size) ((loc) / (size) * (size))
+
+#define REALMODE_ALIGNMENT (CONFIG(SIPI_VECTOR_IN_ROM) ? 4096 : 16)
+#define RESERVED_BELOW_RESET 0xf0
+
SECTIONS {
/* Trigger an error if I have an unuseable start address */
_TOO_LOW = CONFIG_X86_RESET_VECTOR - 0xfff0;
_bogus = ASSERT(_start16bit >= _TOO_LOW, "_start16bit too low. Please report.");
+ .bogus ROMLOC_MIN : {
+ . = ALIGN(4);
+ }
+
+ .bootblock_top . : {
+ . = ALIGN(REALMODE_ALIGNMENT);
+ _realmode = .;
+ *(.bootblock.top);
+ _erealmode = .;
+ }
+
. = CONFIG_X86_RESET_VECTOR;
.reset . : {
*(.reset);
@@ -14,3 +30,10 @@
BYTE(0x00);
}
}
+
+EARLYASM_SIZE = (_erealmode - _realmode);
+/* Assume that 0xf0 below the reset vector (size 0x10), so 0x100 in total is
+ * not available for code.
+ */
+ROMLOC_MIN = ALIGN_DOWN(CONFIG_X86_RESET_VECTOR - RESERVED_BELOW_RESET - EARLYASM_SIZE, \
+ REALMODE_ALIGNMENT);
--
To view, visit https://review.coreboot.org/c/coreboot/+/47193
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I192fd08311fccf2e73a70799de2b028a9c8c4a40
Gerrit-Change-Number: 47193
Gerrit-PatchSet: 1
Gerrit-Owner: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-MessageType: newchange