Yidi Lin has submitted this change. ( https://review.coreboot.org/c/coreboot/+/86391?usp=email )
(
1 is the latest approved patch-set. No files were changed between the latest approved patch-set and the submitted one. )Change subject: mb/google/rauru: Correct GPIO name for BEEP_ON ......................................................................
mb/google/rauru: Correct GPIO name for BEEP_ON
Rename GPIO_BEEP_ON_OD to GPIO_BEEP_ON to match the schematics.
BRANCH=rauru TEST=Build pass BUG=b:317009620
Change-Id: Ica48ed4f4e2cd6a159203ba1f8c17ac371a08f87 Signed-off-by: Jarried Lin jarried.lin@mediatek.corp-partner.google.com Reviewed-on: https://review.coreboot.org/c/coreboot/+/86391 Reviewed-by: Yu-Ping Wu yupingso@google.com Reviewed-by: Yidi Lin yidilin@google.com Tested-by: build bot (Jenkins) no-reply@coreboot.org Reviewed-by: Paul Menzel paulepanter@mailbox.org --- M src/mainboard/google/rauru/chromeos.c M src/mainboard/google/rauru/gpio.h 2 files changed, 3 insertions(+), 3 deletions(-)
Approvals: build bot (Jenkins): Verified Yidi Lin: Looks good to me, approved Paul Menzel: Looks good to me, but someone else must approve Yu-Ping Wu: Looks good to me, approved
diff --git a/src/mainboard/google/rauru/chromeos.c b/src/mainboard/google/rauru/chromeos.c index 6a8431f..b7844b7 100644 --- a/src/mainboard/google/rauru/chromeos.c +++ b/src/mainboard/google/rauru/chromeos.c @@ -14,7 +14,7 @@ gpio_input(GPIO_SD_CD_AP_ODL); gpio_output(GPIO_AP_EC_WARM_RST_REQ, 0); gpio_output(GPIO_AP_FP_FW_UP_STRAP, 0); - gpio_output(GPIO_BEEP_ON_OD, 0); + gpio_output(GPIO_BEEP_ON, 0); gpio_output(GPIO_EN_PWR_FP, 0); gpio_output(GPIO_EN_SPKR, 0); gpio_output(GPIO_FP_RST_1V8_S3_L, 0); @@ -39,7 +39,7 @@
struct lb_gpio nau8318_gpios[] = { {GPIO_EN_SPKR.id, ACTIVE_HIGH, -1, "speaker enable"}, - {GPIO_BEEP_ON_OD.id, ACTIVE_HIGH, -1, "beep enable"}, + {GPIO_BEEP_ON.id, ACTIVE_HIGH, -1, "beep enable"}, };
struct lb_gpio smartamp_gpios[] = { diff --git a/src/mainboard/google/rauru/gpio.h b/src/mainboard/google/rauru/gpio.h index f35135c..fd15463 100644 --- a/src/mainboard/google/rauru/gpio.h +++ b/src/mainboard/google/rauru/gpio.h @@ -5,7 +5,7 @@
#include <soc/gpio.h>
-#define GPIO_BEEP_ON_OD GPIO(PERIPHERAL_EN1) +#define GPIO_BEEP_ON GPIO(PERIPHERAL_EN1) #define GPIO_EN_SPKR GPIO(PERIPHERAL_EN0) #define GPIO_SD_CD_AP_ODL GPIO(EINT11) #define GPIO_GSC_AP_INT_ODL GPIO(EINT18)