Furquan Shaikh has uploaded this change for review. ( https://review.coreboot.org/c/coreboot/+/46029 )
Change subject: drivers/intel/wifi: Drop call to pci_dev_init ......................................................................
drivers/intel/wifi: Drop call to pci_dev_init
`pci_dev_init()` is used to load and run option ROM on VGA class devices (PCI_CLASS_DISPLAY_VGA). WiFi device is not a VGA class device and hence the call to `pci_dev_init()` is not required. This change drops the call to `pci_dev_init()` from `wifi_pci_dev_init()` in Intel WiFi driver.
BUG=b:169802515 BRANCH=zork
Change-Id: I6588ea0a5c848904088d05fd1cbdf677b2dc8ea9 Signed-off-by: Furquan Shaikh furquan@google.com --- M src/drivers/intel/wifi/wifi.c 1 file changed, 0 insertions(+), 2 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/29/46029/1
diff --git a/src/drivers/intel/wifi/wifi.c b/src/drivers/intel/wifi/wifi.c index 0ad0e1c..e117ec0 100644 --- a/src/drivers/intel/wifi/wifi.c +++ b/src/drivers/intel/wifi/wifi.c @@ -63,8 +63,6 @@
static void wifi_pci_dev_init(struct device *dev) { - pci_dev_init(dev); - if (CONFIG(ELOG)) { uint32_t val; val = pci_read_config16(dev, PMCS_DR);
Rob Barnes has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/46029 )
Change subject: drivers/intel/wifi: Drop call to pci_dev_init ......................................................................
Patch Set 1: Code-Review+1
pci_dev_init should probably be renamed because this is misleading.
Duncan Laurie has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/46029 )
Change subject: drivers/intel/wifi: Drop call to pci_dev_init ......................................................................
Patch Set 1: Code-Review+2
Furquan Shaikh has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/46029 )
Change subject: drivers/intel/wifi: Drop call to pci_dev_init ......................................................................
Patch Set 1:
Patch Set 1: Code-Review+1
pci_dev_init should probably be renamed because this is misleading.
I did not check the history on that. Maybe there was more work that was done as part of it some time. But, yeah it would be helpful to have a relevant name.
Michael Niewöhner has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/46029 )
Change subject: drivers/intel/wifi: Drop call to pci_dev_init ......................................................................
Patch Set 1: Code-Review+2
Karthik Ramasubramanian has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/46029 )
Change subject: drivers/intel/wifi: Drop call to pci_dev_init ......................................................................
Patch Set 1: Code-Review+2
Furquan Shaikh has submitted this change. ( https://review.coreboot.org/c/coreboot/+/46029 )
Change subject: drivers/intel/wifi: Drop call to pci_dev_init ......................................................................
drivers/intel/wifi: Drop call to pci_dev_init
`pci_dev_init()` is used to load and run option ROM on VGA class devices (PCI_CLASS_DISPLAY_VGA). WiFi device is not a VGA class device and hence the call to `pci_dev_init()` is not required. This change drops the call to `pci_dev_init()` from `wifi_pci_dev_init()` in Intel WiFi driver.
BUG=b:169802515 BRANCH=zork
Change-Id: I6588ea0a5c848904088d05fd1cbdf677b2dc8ea9 Signed-off-by: Furquan Shaikh furquan@google.com Reviewed-on: https://review.coreboot.org/c/coreboot/+/46029 Tested-by: build bot (Jenkins) no-reply@coreboot.org Reviewed-by: Rob Barnes robbarnes@google.com Reviewed-by: Duncan Laurie dlaurie@chromium.org Reviewed-by: Michael Niewöhner foss@mniewoehner.de Reviewed-by: Karthik Ramasubramanian kramasub@google.com --- M src/drivers/intel/wifi/wifi.c 1 file changed, 0 insertions(+), 2 deletions(-)
Approvals: build bot (Jenkins): Verified Duncan Laurie: Looks good to me, approved Karthik Ramasubramanian: Looks good to me, approved Michael Niewöhner: Looks good to me, approved Rob Barnes: Looks good to me, but someone else must approve
diff --git a/src/drivers/intel/wifi/wifi.c b/src/drivers/intel/wifi/wifi.c index 0ad0e1c..e117ec0 100644 --- a/src/drivers/intel/wifi/wifi.c +++ b/src/drivers/intel/wifi/wifi.c @@ -63,8 +63,6 @@
static void wifi_pci_dev_init(struct device *dev) { - pci_dev_init(dev); - if (CONFIG(ELOG)) { uint32_t val; val = pci_read_config16(dev, PMCS_DR);