Attention is currently required from: Xi Chen, Paul Menzel, Xixi Chen. Yu-Ping Wu has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/61293 )
Change subject: src/mediatek: Refactor dramc_param to common as much as possible ......................................................................
Patch Set 8:
(5 comments)
Commit Message:
https://review.coreboot.org/c/coreboot/+/61293/comment/5b38214f_e4d8423d PS4, Line 7: Refactor dramc_param
This patch is partly for ddr_base_info, but the main purpose is to decrease duplicate code.
Ack
File src/soc/mediatek/common/include/soc/dramc_param_common.h:
https://review.coreboot.org/c/coreboot/+/61293/comment/4bd8b48a_f6210a58 PS8, Line 26: enum SDRAM_DVFS_FLAG { : DRAMC_DISABLE_DVFS, : DRAMC_ENABLE_DVFS, : }; : : enum SDRAM_DDR_TYPE { : DDR_TYPE_DISCRETE, : DDR_TYPE_EMCP, : }; : : enum SDRAM_DDR_GEOMETRY_TYPE { : DDR_TYPE_2CH_2RK_4GB_2_2, : DDR_TYPE_2CH_2RK_6GB_3_3, : DDR_TYPE_2CH_2RK_8GB_4_4_BYTE, : DDR_TYPE_2CH_1RK_4GB_4_0, : DDR_TYPE_2CH_2RK_6GB_2_4, : DDR_TYPE_2CH_2RK_8GB_4_4, : }; : : enum SDRAM_VOLTAGE_TYPE { : SDRAM_VOLTAGE_NVCORE_NVDRAM, : SDRAM_VOLTAGE_HVCORE_HVDRAM, : SDRAM_VOLTAGE_LVCORE_LVDRAM, : }; Can we move each enum to where it's used? For example, move SDRAM_VOLTAGE_TYPE right above ddr_base_info. Then this file will look like:
dramc_param_header-related enums dramc_param_header struct sdram_info-related enums sdram_info struct emi_mdl ddr_mrr_info ddr_base_info-related enums ddr_base_info struct
https://review.coreboot.org/c/coreboot/+/61293/comment/5b927ed9_52c736ab PS8, Line 62: Take the chance to remove the extra tab.
https://review.coreboot.org/c/coreboot/+/61293/comment/8abbd2bc_a6426f37 PS8, Line 87: One space.
File src/soc/mediatek/mt8195/include/soc/dramc_param.h:
https://review.coreboot.org/c/coreboot/+/61293/comment/a602034f_a8f43a85 PS8, Line 14: RANK INFO Was this added intentionally?