Attention is currently required from: Hung-Te Lin, Jarried Lin.
Yu-Ping Wu has posted comments on this change by Jarried Lin. ( https://review.coreboot.org/c/coreboot/+/85952?usp=email )
Change subject: mb/google/rauru: Enable firmware display ......................................................................
Patch Set 3:
(1 comment)
File src/mainboard/google/rauru/mainboard.c:
https://review.coreboot.org/c/coreboot/+/85952/comment/1c7a9cb1_c07a4d84?usp... : PS1, Line 103: mt6373_init_pmif_arb();
@yupingso@google. […]
I'd prefer fixing SD card in a separate patch.
And I think it should be fine to call `mt6373_init_pmif_arb()` twice (once here and the other in `if (CONFIG(RAURU_SDCARD_INIT))`), as the extra `pmif_check_init_done` overhead should be pretty small.
That said, I think a better approach is to modify all `mtXXXX_init_pmif_arb`, so that a second call to it would be a no-op. For example:
``` void mt6373_init_pmif_arb(void) { if (pmif_arb) return;
pmif_arb = get_pmif_controller(PMIF_SPMI, SPMI_MASTER_1); assert(pmif_arb);
// BTW we should rename this to pmif_check_init_done if (pmif_arb->is_pmif_init_done(pmif_arb)) ...
printk(...); } ```