Attention is currently required from: Tarun Tuli, David Wu, Ren Kuo, Reka Norman, Tyler Wang, Eric Lai.
Nick Vaccaro has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/69693 )
Change subject: mb/google/brya/var/craask: Modify GPIOs for craaskneto/craaskino ......................................................................
Patch Set 6:
(4 comments)
File src/mainboard/google/brya/variants/craask/fw_config.c:
https://review.coreboot.org/c/coreboot/+/69693/comment/faf2b28e_4cb5d645 PS6, Line 67: /* craask: board id = 0x00 ~ 0x1f */
code indent should use tabs where possible
Please fix.
https://review.coreboot.org/c/coreboot/+/69693/comment/9aa1f5b8_c181e25d PS6, Line 95: /* craaskneto/craaskino: board id >= 0x20 */
code indent should use tabs where possible
Please fix.
https://review.coreboot.org/c/coreboot/+/69693/comment/8ba505a7_e514551c PS6, Line 103: gpio_padbased_override(padbased_table, wfc_disable_pads, Since you're disabling MIPI WFC in both cases ((id >= 0x20) || (id < 0x20)), why not just set the pads as disabled in the main gpio tables in variant/craask/gpio.c?
File src/mainboard/google/brya/variants/craask/gpio.c:
https://review.coreboot.org/c/coreboot/+/69693/comment/8b855118_53d30a62 PS6, Line 160: 0x20 This magic number 0x20 is used a fair amount in different source files, would be nice to assign a variable name to it, perhaps something like "KNETO_KINO_BOARD_ID_MIN" ?