Marc Jones has submitted this change. ( https://review.coreboot.org/c/coreboot/+/46836 )
Change subject: mb/ocp/deltalake: Rename motherboard_fill_fadt() ......................................................................
mb/ocp/deltalake: Rename motherboard_fill_fadt()
Rename motherboard_fill_fadt() to the common override mainboard_fill_fadt() function to override FADT.
Tested=On OCP Delta Lake, verify FADT PM Profile is set to Enterprise Server.
Signed-off-by: Jingle Hsu jingle_hsu@wiwynn.com Change-Id: Ie9ea7cc6e712d0aca57bbeac1a4154921d123be4 Reviewed-on: https://review.coreboot.org/c/coreboot/+/46836 Tested-by: build bot (Jenkins) no-reply@coreboot.org Reviewed-by: Angel Pons th3fanbus@gmail.com --- M src/mainboard/ocp/deltalake/fadt.c M src/soc/intel/xeon_sp/include/soc/acpi.h 2 files changed, 1 insertion(+), 2 deletions(-)
Approvals: build bot (Jenkins): Verified Angel Pons: Looks good to me, approved
diff --git a/src/mainboard/ocp/deltalake/fadt.c b/src/mainboard/ocp/deltalake/fadt.c index b9fcd58..6306e03 100644 --- a/src/mainboard/ocp/deltalake/fadt.c +++ b/src/mainboard/ocp/deltalake/fadt.c @@ -3,7 +3,7 @@ #include <acpi/acpi.h> #include <soc/acpi.h>
-void motherboard_fill_fadt(acpi_fadt_t *fadt) +void mainboard_fill_fadt(acpi_fadt_t *fadt) { fadt->preferred_pm_profile = PM_ENTERPRISE_SERVER; } diff --git a/src/soc/intel/xeon_sp/include/soc/acpi.h b/src/soc/intel/xeon_sp/include/soc/acpi.h index 61639d2..60d6321 100644 --- a/src/soc/intel/xeon_sp/include/soc/acpi.h +++ b/src/soc/intel/xeon_sp/include/soc/acpi.h @@ -20,7 +20,6 @@ unsigned long northbridge_write_acpi_tables(const struct device *device, unsigned long current, struct acpi_rsdp *rsdp);
-void motherboard_fill_fadt(acpi_fadt_t *fadt);
int calculate_power(int tdp, int p1_ratio, int ratio); void uncore_inject_dsdt(const struct device *device);