Felix Held has uploaded this change for review. ( https://review.coreboot.org/c/coreboot/+/56187 )
Change subject: security/intel/txt: use mca_get_bank_count() ......................................................................
security/intel/txt: use mca_get_bank_count()
Use the common mca_get_bank_count function instead of open-coding the functionality to get the MCA bank number.
Change-Id: I28244c975ee34d36d0b44df092d4a62a01c3c79c Signed-off-by: Felix Held felix-coreboot@felixheld.de --- M src/security/intel/txt/common.c 1 file changed, 1 insertion(+), 2 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/87/56187/1
diff --git a/src/security/intel/txt/common.c b/src/security/intel/txt/common.c index 239e152..011e8cc 100644 --- a/src/security/intel/txt/common.c +++ b/src/security/intel/txt/common.c @@ -481,8 +481,7 @@ * Make sure there are no uncorrectable MCE errors. * Intel 64 and IA-32 Architectures Software Developer Manuals Vol 2D */ - msr = rdmsr(IA32_MCG_CAP); - size_t max_mc_msr = msr.lo & MCA_BANKS_MASK; + size_t max_mc_msr = mca_get_bank_count(); for (size_t i = 0; i < max_mc_msr; i++) { msr = rdmsr(IA32_MC0_STATUS + 4 * i); if (!(msr.hi & MCA_STATUS_HI_UC))