Attention is currently required from: Hung-Te Lin, Paul Menzel, Yidi Lin.
Yu-Ping Wu has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/79776?usp=email )
Change subject: soc/mediatek: Add common implmentation to configure display ......................................................................
Patch Set 1:
(8 comments)
Commit Message:
https://review.coreboot.org/c/coreboot/+/79776/comment/bc69738e_b29da548 : PS1, Line 13: mtcmos_display_power_on nit: `mtcmos_display_power_on()`
https://review.coreboot.org/c/coreboot/+/79776/comment/bbc5d2fd_545ea20e : PS1, Line 28: soc nit: `mediatek`
https://review.coreboot.org/c/coreboot/+/79776/comment/1f5bcdc2_6f99a6fe : PS1, Line 29: refacts Do you mean `refactors`?
File src/mainboard/google/geralt/panel.h:
https://review.coreboot.org/c/coreboot/+/79776/comment/9d825f48_e693c00d : PS1, Line 23: struct panel_description *get_active_panel(void); I think the declaration should be kept here, because the implementation is in geralt/panel.c.
File src/soc/mediatek/common/display.c:
https://review.coreboot.org/c/coreboot/+/79776/comment/5240a02b_c853c63a : PS1, Line 13: configure_display Consider renaming it to `mtk_display_init`?
https://review.coreboot.org/c/coreboot/+/79776/comment/3d4ed732_101c102f : PS1, Line 42: if (panel->get_edid && panel->get_edid(panel) < 0) So, this is only for eDP bridges, right? For consistency, I think `get_mipi_cmd_from_cbfs()`, which also sets `panel->s->edid`, can also be moved to soc/meditek/common/. That would also reduce duplicate code for MediaTek boards (for example corsola also has `get_panel_from_cbfs()`). Then the logic here can be
``` if (panel->get_edid) { panel->get_edid(panel); } else { panel_serializable_data mipi_data; get_mipi_panel_from_cbfs(&mipi_data); } ```
And `s` can also be removed from `panel`. What do you think?
File src/soc/mediatek/common/include/soc/ddp_common.h:
https://review.coreboot.org/c/coreboot/+/79776/comment/6cfab11e_34262aca : PS1, Line 142: enum disp_path_sel { I think this should be put in mediatek/common/.../display.h, and then include display.h from mt8188/.../ddp.h (not the other way around).
File src/soc/mediatek/common/include/soc/display.h:
https://review.coreboot.org/c/coreboot/+/79776/comment/694f054f_98fff66b : PS1, Line 13: configure_panel_backlight configure_backlight