Attention is currently required from: Tim Wawrzynczak, Aamir Bohra. Furquan Shaikh has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/51271 )
Change subject: src/cpu/x86: Add helper mp_run_on_all_aps ......................................................................
Patch Set 1: Code-Review+1
(3 comments)
Patchset:
PS1: Looks okay to me. Let's just wait some more time in case there are any other comments.
File src/cpu/x86/mp_init.c:
https://review.coreboot.org/c/coreboot/+/51271/comment/60395451_31485aea PS1, Line 998: run_serial nit: If you flip the organization, you won't need the additional tab on if block.
if (!run_serial) return mp_run_on_aps(func, arg, 0, expire_us);
for (...) { }
return 0;
To avoid the negative check, you can rename run_serial to run_parallel instead.
https://review.coreboot.org/c/coreboot/+/51271/comment/f8198957_c3cd6c03 PS1, Line 1000: */ Assumption is that this call is made from BSP only.