Attention is currently required from: Selma Bensaid, Sridhar Siricilla, Rizwan Qureshi. Werner Zeh has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/56073 )
Change subject: mb/intel/adlrvp: Update PMC Descriptor for Alder lake A0(906a0h) silicon ......................................................................
Patch Set 6: Code-Review+1
(5 comments)
File src/mainboard/intel/adlrvp/bootblock.c:
https://review.coreboot.org/c/coreboot/+/56073/comment/1b5c6f9c_ef49f992 PS6, Line 13: #define SI_DESC_REGION_SZ 4096 nit: This size could be included from fmap_config.h. But I do not insist since the size of the descriptor is fixed.
https://review.coreboot.org/c/coreboot/+/56073/comment/fb398cc4_802792d8 PS6, Line 25: check_host_write_access_desc_region I would name it more distinct, maybe something like is_descriptor_writeable() or the like. And I guess you can drop the "host" part since it is clear here.
https://review.coreboot.org/c/coreboot/+/56073/comment/4c4fbb8e_1edb7c9f PS6, Line 28: if (*(uint32_t *)(desc + FLASH_SIGN_OFFSET) != FLASH_VAL_SIGN) { Would it make things more readable here if you use read32 here? Maybe something like: if (read32((void *)(desc + FLASH_SIGN_OFFSET)) != FLASH_VAL_SIGN)
https://review.coreboot.org/c/coreboot/+/56073/comment/2676aaf2_0b15bb63 PS6, Line 36: *flmstr1 Use read32() here as well?
https://review.coreboot.org/c/coreboot/+/56073/comment/665ab6ea_5bee7fe6 PS6, Line 81: BIOS_DEBUG Should we use a lower log level here since it is a reset now? It just happens once, right?