Attention is currently required from: Felix Held, Jérémy Compostella, Maximilian Brune, Naresh Solanki.
Angel Pons has posted comments on this change by Naresh Solanki. ( https://review.coreboot.org/c/coreboot/+/85638?usp=email )
Change subject: arch/x86/cpu: Mark fill_cpu_cache_info as weak ......................................................................
Patch Set 1: Code-Review+1
(1 comment)
File src/arch/x86/cpu_common.c:
https://review.coreboot.org/c/coreboot/+/85638/comment/9e2318c2_fd93abf0?usp... : PS1, Line 224: struct cpuid_result cache_info_res = cpuid_ext(leaf, level); : : info->type = CPUID_CACHE_TYPE(cache_info_res); : info->level = CPUID_CACHE_LEVEL(cache_info_res); : info->num_ways = CPUID_CACHE_WAYS_OF_ASSOC(cache_info_res) + 1; : info->num_sets = CPUID_CACHE_NO_OF_SETS(cache_info_res) + 1; : info->line_size = CPUID_CACHE_COHER_LINE(cache_info_res) + 1; : info->physical_partitions = CPUID_CACHE_PHYS_LINE(cache_info_res) + 1; : info->num_cores_shared = CPUID_CACHE_SHARING_CACHE(cache_info_res) + 1; : info->fully_associative = CPUID_CACHE_FULL_ASSOC(cache_info_res); : info->size = get_cache_size(info); : Looking at follow-ups, would it make sense to extract this part into a helper function?