the following patch was just integrated into master: commit b5669ba57937f48ffe201395c3e3b1527c14d1fa Author: Alexandru Gagniuc mr.nuke.me@gmail.com Date: Fri Jan 30 00:07:12 2015 -0600
drivers/pc80/mc146818rtc: Reduce superfluous preprocessor use
cmos_init() had layers of preprocessor directives, which resulted in a complete mess. Refactor it to make use of the IS_ENABLED() macro. This improves readability significantly.
One of the changes is to remove in inline stub declaration of (get|set)_option. Although that provided the ability for the compiler to optimize out code when USE_OPTION_TABLE is not selected, there is no evidence that such savings are measureable.
Change-Id: I07f00084d809adbb55031b2079f71136ade3028e Signed-off-by: Alexandru Gagniuc mr.nuke.me@gmail.com Reviewed-on: http://review.coreboot.org/8306 Tested-by: build bot (Jenkins) Reviewed-by: Kyösti Mälkki kyosti.malkki@gmail.com
See http://review.coreboot.org/8306 for details.
-gerrit