Jamie Chen has uploaded this change for review. ( https://review.coreboot.org/c/coreboot/+/35093 )
Change subject: soc/intel/common: Include cometlake EMMC controller ID ......................................................................
soc/intel/common: Include cometlake EMMC controller ID
Add cometlake EMMC controller ID
BUG=none BRANCH=none TEST=none
Change-Id: I3943dad57918df3df7885c2e2d3a86ab0e1d6008 Signed-off-by: Jamie Chen jamie.chen@intel.com --- M src/include/device/pci_ids.h 1 file changed, 1 insertion(+), 0 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/93/35093/1
diff --git a/src/include/device/pci_ids.h b/src/include/device/pci_ids.h index 2501640..b4cbc38 100644 --- a/src/include/device/pci_ids.h +++ b/src/include/device/pci_ids.h @@ -3221,6 +3221,7 @@ #define PCI_DEVICE_ID_INTEL_CNP_H_SD 0xa375 #define PCI_DEVICE_ID_INTEL_ICL_SD 0x34f8 #define PCI_DEVICE_ID_INTEL_CMP_SD 0x02f5 +#define PCI_DEVICE_ID_INTEL_CMP_MMC 0x02c4
/* Intel EMMC device Ids */ #define PCI_DEVICE_ID_INTEL_SKL_EMMC 0x9d2b
Subrata Banik has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/35093 )
Change subject: soc/intel/common: Include cometlake EMMC controller ID ......................................................................
Patch Set 1:
(1 comment)
https://review.coreboot.org/c/coreboot/+/35093/1/src/include/device/pci_ids.... File src/include/device/pci_ids.h:
https://review.coreboot.org/c/coreboot/+/35093/1/src/include/device/pci_ids.... PS1, Line 3224: PCI_DEVICE_ID_INTEL_CMP_MMC can you add this at line 3228?
Kane Chen has uploaded a new patch set (#2) to the change originally created by Jamie Chen. ( https://review.coreboot.org/c/coreboot/+/35093 )
Change subject: soc/intel/common: Include cometlake EMMC controller ID ......................................................................
soc/intel/common: Include cometlake EMMC controller ID
Add cometlake EMMC controller ID
BUG=none BRANCH=none TEST=none
Change-Id: I3943dad57918df3df7885c2e2d3a86ab0e1d6008 Signed-off-by: Jamie Chen jamie.chen@intel.com --- M src/include/device/pci_ids.h 1 file changed, 1 insertion(+), 0 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/93/35093/2
Subrata Banik has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/35093 )
Change subject: soc/intel/common: Include cometlake EMMC controller ID ......................................................................
Patch Set 2: Code-Review+1
(1 comment)
https://review.coreboot.org/c/coreboot/+/35093/2/src/include/device/pci_ids.... File src/include/device/pci_ids.h:
https://review.coreboot.org/c/coreboot/+/35093/2/src/include/device/pci_ids.... PS2, Line 3227: #define PCI_DEVICE_ID_INTEL_CMP_MMC 0x02c4 this could be PCI_DEVICE_ID_INTEL_CMP_EMMC just to make naming consistence across
Kane Chen has uploaded a new patch set (#3) to the change originally created by Jamie Chen. ( https://review.coreboot.org/c/coreboot/+/35093 )
Change subject: soc/intel/common: Include cometlake EMMC controller ID ......................................................................
soc/intel/common: Include cometlake EMMC controller ID
Add cometlake EMMC controller ID
BUG=none BRANCH=none TEST=none
Change-Id: I3943dad57918df3df7885c2e2d3a86ab0e1d6008 Signed-off-by: Jamie Chen jamie.chen@intel.com --- M src/include/device/pci_ids.h 1 file changed, 1 insertion(+), 0 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/93/35093/3
Subrata Banik has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/35093 )
Change subject: soc/intel/common: Include cometlake EMMC controller ID ......................................................................
Patch Set 3: Code-Review+2
Subrata Banik has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/35093 )
Change subject: soc/intel/common: Include cometlake EMMC controller ID ......................................................................
Patch Set 3:
(1 comment)
https://review.coreboot.org/c/coreboot/+/35093/2/src/include/device/pci_ids.... File src/include/device/pci_ids.h:
https://review.coreboot.org/c/coreboot/+/35093/2/src/include/device/pci_ids.... PS2, Line 3227: #define PCI_DEVICE_ID_INTEL_CMP_MMC 0x02c4
this could be PCI_DEVICE_ID_INTEL_CMP_EMMC just to make naming consistence across
Ack
Subrata Banik has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/35093 )
Change subject: soc/intel/common: Include cometlake EMMC controller ID ......................................................................
Patch Set 3:
(1 comment)
https://review.coreboot.org/c/coreboot/+/35093/1/src/include/device/pci_ids.... File src/include/device/pci_ids.h:
https://review.coreboot.org/c/coreboot/+/35093/1/src/include/device/pci_ids.... PS1, Line 3224: PCI_DEVICE_ID_INTEL_CMP_MMC
can you add this at line 3228?
Ack
Patrick Georgi has submitted this change and it was merged. ( https://review.coreboot.org/c/coreboot/+/35093 )
Change subject: soc/intel/common: Include cometlake EMMC controller ID ......................................................................
soc/intel/common: Include cometlake EMMC controller ID
Add cometlake EMMC controller ID
BUG=none BRANCH=none TEST=none
Change-Id: I3943dad57918df3df7885c2e2d3a86ab0e1d6008 Signed-off-by: Jamie Chen jamie.chen@intel.com Reviewed-on: https://review.coreboot.org/c/coreboot/+/35093 Tested-by: build bot (Jenkins) no-reply@coreboot.org Reviewed-by: Subrata Banik subrata.banik@intel.com --- M src/include/device/pci_ids.h 1 file changed, 1 insertion(+), 0 deletions(-)
Approvals: build bot (Jenkins): Verified Subrata Banik: Looks good to me, approved
diff --git a/src/include/device/pci_ids.h b/src/include/device/pci_ids.h index 2501640..cdd1c62 100644 --- a/src/include/device/pci_ids.h +++ b/src/include/device/pci_ids.h @@ -3224,6 +3224,7 @@
/* Intel EMMC device Ids */ #define PCI_DEVICE_ID_INTEL_SKL_EMMC 0x9d2b +#define PCI_DEVICE_ID_INTEL_CMP_EMMC 0x02c4
/* Intel WIFI Ids */ #define PCI_DEVICE_ID_1000_SERIES_WIFI 0x0084