Arthur Heymans has posted comments on this change. ( https://review.coreboot.org/19503 )
Change subject: nb/intel/gm45/gma.c: Decode EDID before NGI path ......................................................................
Patch Set 9:
(4 comments)
https://review.coreboot.org/#/c/19503/6/src/northbridge/intel/gm45/gma.c File src/northbridge/intel/gm45/gma.c:
PS6, Line 669: gtt_res
The original code would dereference the NULL in gma_pm_init_
ok.
https://review.coreboot.org/#/c/19503/9/src/northbridge/intel/gm45/gma.c File src/northbridge/intel/gm45/gma.c:
Line 692: if (IS_ENABLED(CONFIG_MAINBOARD_DO_NATIVE_VGA_INIT)) {
Maybe move the whole if body into a new function to save an
And passing pointer to edid_lvds as argument?
PS9, Line 709: gtt_res && gtt_res->base &&
... this could be removed then.
ok
Line 710: && pio_res->base && lfb_res && lfb_res->base) {
We could also bail out here if anything is unset. This would save
ok