Hello Joel Kitching, Patrick Georgi,
I'd like you to do a code review. Please visit
https://review.coreboot.org/c/coreboot/+/37772
to review the following change.
Change subject: vboot: Fix MOCK_SECDATA for new naming scheme ......................................................................
vboot: Fix MOCK_SECDATA for new naming scheme
CB:37655 updated all secdata_xxx to secdata_firmware_xxx, but forgot the code that's only compiled when MOCK_SECDATA is set. This patch fixes it.
Change-Id: Icf12fe405d7ce46345ccbdcb76f6aa1b56ed0194 Signed-off-by: Julius Werner jwerner@chromium.org --- M src/security/vboot/secdata_mock.c 1 file changed, 1 insertion(+), 1 deletion(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/72/37772/1
diff --git a/src/security/vboot/secdata_mock.c b/src/security/vboot/secdata_mock.c index de58bf5..a6c4afb 100644 --- a/src/security/vboot/secdata_mock.c +++ b/src/security/vboot/secdata_mock.c @@ -45,7 +45,7 @@
vb2_error_t antirollback_read_space_firmware(struct vb2_context *ctx) { - vb2api_secdata_create(ctx); + vb2api_secdata_firmware_create(ctx); return VB2_SUCCESS; }