Attention is currently required from: Dinesh Gehlot, Eran Mitrani, Intel coreboot Reviewers, Jakub "Kuba" Czapiga, Jayvik Desai, Kapil Porwal, Nick Vaccaro, Subrata Banik, Tarun.
Julius Werner has posted comments on this change by Subrata Banik. ( https://review.coreboot.org/c/coreboot/+/86283?usp=email )
Change subject: lib: Refactor ux_locales_get_text API
......................................................................
Patch Set 5:
(4 comments)
File src/include/ux_locales.h:
https://review.coreboot.org/c/coreboot/+/86283/comment/2e4b907e_cf83855e?usp... :
PS5, Line 23: const char *ux_locales_get_text(const char *name, const char *fallback_text);
Why should we still keep this API around? I think we should switch everything to using IDs.
File src/lib/ux_locales.c:
https://review.coreboot.org/c/coreboot/+/86283/comment/5be5f0cc_6e3b221a?usp... :
PS5, Line 28: "Please do not turn off your device."
nit: I don't think there's a point in `#define`ing these up here, rather than just putting them directly in the array initializer below (since they are only used once there).
https://review.coreboot.org/c/coreboot/+/86283/comment/6ae0184e_741be927?usp... :
PS5, Line 32: enum ux_locale_msg locale_msg_id;
Is locale_msg_id used ? […]
+1
https://review.coreboot.org/c/coreboot/+/86283/comment/cf66f950_f4a52db9?usp... :
PS5, Line 213: switch (msg_id) {
Could we have a `MAX_UX_LOCALE` to avoid having to add every single enum in this switch case stateme […]
+1
I'd call it `UX_LOCALE_MSG_NUM`, to retain the same prefix and since you probably want the number of entries (last ID + 1), rather than the maximum (last ID).
--
To view, visit
https://review.coreboot.org/c/coreboot/+/86283?usp=email
To unsubscribe, or for help writing mail filters, visit
https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: I4952802396265b9ee8d164d6e43a7f2b3599d6c0
Gerrit-Change-Number: 86283
Gerrit-PatchSet: 5
Gerrit-Owner: Subrata Banik
subratabanik@google.com
Gerrit-Reviewer: Dinesh Gehlot
digehlot@google.com
Gerrit-Reviewer: Eran Mitrani
mitrani@google.com
Gerrit-Reviewer: Intel coreboot Reviewers
intel_coreboot_reviewers@intel.com
Gerrit-Reviewer: Jakub "Kuba" Czapiga
czapiga@google.com
Gerrit-Reviewer: Jayvik Desai
jayvik@google.com
Gerrit-Reviewer: Julius Werner
jwerner@chromium.org
Gerrit-Reviewer: Kapil Porwal
kapilporwal@google.com
Gerrit-Reviewer: Nick Vaccaro
nvaccaro@chromium.org
Gerrit-Reviewer: Tarun
tstuli@gmail.com
Gerrit-Reviewer: build bot (Jenkins)
no-reply@coreboot.org
Gerrit-CC: Jérémy Compostella
jeremy.compostella@intel.com
Gerrit-Attention: Jayvik Desai
jayvik@google.com
Gerrit-Attention: Intel coreboot Reviewers
intel_coreboot_reviewers@intel.com
Gerrit-Attention: Eran Mitrani
mitrani@google.com
Gerrit-Attention: Subrata Banik
subratabanik@google.com
Gerrit-Attention: Jakub "Kuba" Czapiga
czapiga@google.com
Gerrit-Attention: Kapil Porwal
kapilporwal@google.com
Gerrit-Attention: Dinesh Gehlot
digehlot@google.com
Gerrit-Attention: Nick Vaccaro
nvaccaro@chromium.org
Gerrit-Attention: Tarun
tstuli@gmail.com
Gerrit-Comment-Date: Fri, 07 Feb 2025 00:27:28 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Jérémy Compostella
jeremy.compostella@intel.com