Felix Held has submitted this change. ( https://review.coreboot.org/c/coreboot/+/59820 )
Change subject: region: Rename rdev_readat_full to rdev_read_full ......................................................................
region: Rename rdev_readat_full to rdev_read_full
The 'at' part of the name refers to starting to read from a specific offset, so it doesn't make sense for the 'full' version of the function.
Signed-off-by: Julius Werner jwerner@chromium.org Change-Id: I60d595f0cbd161df171eaa4a76c7a00b6377e2b0 Reviewed-on: https://review.coreboot.org/c/coreboot/+/59820 Reviewed-by: Raul Rangel rrangel@chromium.org Tested-by: build bot (Jenkins) no-reply@coreboot.org --- M src/commonlib/include/commonlib/region.h M src/lib/cbfs.c 2 files changed, 2 insertions(+), 2 deletions(-)
Approvals: build bot (Jenkins): Verified Raul Rangel: Looks good to me, approved
diff --git a/src/commonlib/include/commonlib/region.h b/src/commonlib/include/commonlib/region.h index 5d73d9e..25efcc8 100644 --- a/src/commonlib/include/commonlib/region.h +++ b/src/commonlib/include/commonlib/region.h @@ -163,7 +163,7 @@ * * You must ensure the buffer is large enough to hold the full region_device. */ -static inline ssize_t rdev_readat_full(const struct region_device *rd, void *b) +static inline ssize_t rdev_read_full(const struct region_device *rd, void *b) { return rdev_readat(rd, b, 0, region_device_sz(rd)); } diff --git a/src/lib/cbfs.c b/src/lib/cbfs.c index 600d259..b4b6eb1 100644 --- a/src/lib/cbfs.c +++ b/src/lib/cbfs.c @@ -316,7 +316,7 @@ { struct cbfs_preload_context *context = arg;
- if (rdev_readat_full(&context->rdev, context->buffer) < 0) { + if (rdev_read_full(&context->rdev, context->buffer) < 0) { ERROR("%s(name='%s') readat failed\n", __func__, context->name); return CB_ERR; }