Julius Werner has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/38421 )
Change subject: commonlib/bsd: Add new CBFS core implementation ......................................................................
Patch Set 8:
(1 comment)
https://review.coreboot.org/c/coreboot/+/38421/8/src/commonlib/bsd/cbfs_priv... File src/commonlib/bsd/cbfs_private.c:
https://review.coreboot.org/c/coreboot/+/38421/8/src/commonlib/bsd/cbfs_priv... PS8, Line 44: while ((ret_header = read_next_header(dev, &offset, &mdata.h)) == CB_SUCCESS) {
isn't that the same as "do not use assignment in if condition"?
Who knows what it does...
FWIW, I'm not planning to fix any of these unless anyone really wants me to. This is just checkpatch stuff that was written for Linux, I'm not aware that that the coreboot style forbids these explicitly, and I think in the few places I use them they enhance readability (e.g. you couldn't really write this while-loop otherwise, you'd have to work around it by calling read_next_header() in multiple places instead and it would just make it way harder to understand the fundamental flow here).