build bot (Jenkins) has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/33282 )
Change subject: spi_flash: Make .read() callback optional ......................................................................
Patch Set 1:
(6 comments)
https://review.coreboot.org/#/c/33282/1/src/drivers/spi/spi_flash.c File src/drivers/spi/spi_flash.c:
https://review.coreboot.org/#/c/33282/1/src/drivers/spi/spi_flash.c@52 PS1, Line 52: if ((ret = spi_claim_bus(spi))) do not use assignment in if condition
https://review.coreboot.org/#/c/33282/1/src/drivers/spi/spi_flash.c@100 PS1, Line 100: int (*do_cmd)(const struct spi_slave *, const void *, size_t, function definition argument 'const struct spi_slave *' should also have an identifier name
https://review.coreboot.org/#/c/33282/1/src/drivers/spi/spi_flash.c@100 PS1, Line 100: int (*do_cmd)(const struct spi_slave *, const void *, size_t, function definition argument 'const void *' should also have an identifier name
https://review.coreboot.org/#/c/33282/1/src/drivers/spi/spi_flash.c@100 PS1, Line 100: int (*do_cmd)(const struct spi_slave *, const void *, size_t, function definition argument 'size_t' should also have an identifier name
https://review.coreboot.org/#/c/33282/1/src/drivers/spi/spi_flash.c@100 PS1, Line 100: int (*do_cmd)(const struct spi_slave *, const void *, size_t, function definition argument 'void *' should also have an identifier name
https://review.coreboot.org/#/c/33282/1/src/drivers/spi/spi_flash.c@100 PS1, Line 100: int (*do_cmd)(const struct spi_slave *, const void *, size_t, function definition argument 'size_t' should also have an identifier name