Felix Held has uploaded this change for review. ( https://review.coreboot.org/c/coreboot/+/33628
Change subject: arch-x86/smbios: use ALIGN_UP instead of ALIGN for better readability ......................................................................
arch-x86/smbios: use ALIGN_UP instead of ALIGN for better readability
ALIGN_UP is an alias for ALIGN.
Change-Id: Ie723ebe80f8f627021151413cb43adce6c88a0dc Signed-off-by: Felix Held felix-coreboot@felixheld.de --- M src/arch/x86/smbios.c 1 file changed, 2 insertions(+), 2 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/28/33628/1
diff --git a/src/arch/x86/smbios.c b/src/arch/x86/smbios.c index 54c2b09..50dac7f 100644 --- a/src/arch/x86/smbios.c +++ b/src/arch/x86/smbios.c @@ -1150,12 +1150,12 @@ int max_struct_size = 0; int handle = 0;
- current = ALIGN(current, 16); + current = ALIGN_UP(current, 16); printk(BIOS_DEBUG, "%s: %08lx\n", __func__, current);
se = (struct smbios_entry *)current; current += sizeof(struct smbios_entry); - current = ALIGN(current, 16); + current = ALIGN_UP(current, 16);
tables = current; update_max(len, max_struct_size, smbios_write_type0(¤t,