Yu-Ping Wu has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/38400 )
Change subject: soc/mediatek: dsi: reduce the hbp and hfp for phy timing ......................................................................
Patch Set 5:
(3 comments)
https://review.coreboot.org/c/coreboot/+/38400/2//COMMIT_MSG Commit Message:
https://review.coreboot.org/c/coreboot/+/38400/2//COMMIT_MSG@17 PS2, Line 17:
Add […]
Done
https://review.coreboot.org/c/coreboot/+/38400/2/src/soc/mediatek/common/dsi... File src/soc/mediatek/common/dsi.c:
https://review.coreboot.org/c/coreboot/+/38400/2/src/soc/mediatek/common/dsi... PS2, Line 213: hfp_byte + hbp_byte)
this is repeated 3 times so let's make a variable for it, for example: […]
I think writing it this way is easier to read.
https://review.coreboot.org/c/coreboot/+/38400/3/src/soc/mediatek/common/dsi... File src/soc/mediatek/common/dsi.c:
https://review.coreboot.org/c/coreboot/+/38400/3/src/soc/mediatek/common/dsi... PS3, Line 214: hfp_byte -= (d_phy * hfp_byte) / (hfp_byte + hbp_byte); : hbp_byte -= (d_phy * hbp_byte) / (hfp_byte + hbp_byte);
This is different from kernel. See CL:2053515.
Done