HAOUAS Elyes has uploaded this change for review. ( https://review.coreboot.org/c/coreboot/+/44841 )
Change subject: mb/roda/rk886ex: Use PNP_IDX_EN instead of magic number ......................................................................
mb/roda/rk886ex: Use PNP_IDX_EN instead of magic number
Change-Id: Ic8b5d94f8fb321d02400247ef86b4725a067ba76 Signed-off-by: Elyes HAOUAS ehaouas@noos.fr --- M src/mainboard/roda/rk886ex/early_init.c 1 file changed, 2 insertions(+), 1 deletion(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/41/44841/1
diff --git a/src/mainboard/roda/rk886ex/early_init.c b/src/mainboard/roda/rk886ex/early_init.c index 21f115c..37682d6 100644 --- a/src/mainboard/roda/rk886ex/early_init.c +++ b/src/mainboard/roda/rk886ex/early_init.c @@ -4,6 +4,7 @@ #include <stdint.h> #include <arch/io.h> #include <cf9_reset.h> +#include <device/pnp_def.h> #include <device/pnp_ops.h> #include <device/pci_ops.h> #include <device/pci_def.h> @@ -50,7 +51,7 @@ pnp_write_config(dev, 0x27, (6 << 4) | 7); /* FDC + PP DMA */ pnp_write_config(dev, 0x28, (4 << 4) | 3); /* UART1,2 IRQ */ /* These are the SMI status registers in the SIO: */ - pnp_write_config(dev, 0x30, (0x600 >> 4)); /* Runtime Register Block Base */ + pnp_write_config(dev, PNP_IDX_EN, (0x600 >> 4)); /* Runtime Register Block Base */
pnp_write_config(dev, 0x31, 0x00); /* GPIO1 DIR */ pnp_write_config(dev, 0x32, 0x00); /* GPIO1 POL */