Angel Pons has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/41473 )
Change subject: inteltool: Support dumping IOBP register values ......................................................................
Patch Set 3:
(3 comments)
https://review.coreboot.org/c/coreboot/+/41473/3/util/inteltool/iobp.c File util/inteltool/iobp.c:
https://review.coreboot.org/c/coreboot/+/41473/3/util/inteltool/iobp.c@8 PS3, Line 8: rcba
What is hidden?
`rcba`. If you use this macro, a variable named `rcba` needs to be declared
https://review.coreboot.org/c/coreboot/+/41473/3/util/inteltool/iobp.c@13 PS3, Line 13: #define IOBPIRI 0x2330 : #define IOBPD 0x2334 : #define IOBPS 0x2338 : #define IOBPS_READY 0x0001 : #define IOBPS_TX_MASK 0x0006 : #define IOBPS_MASK 0xff00 : #define IOBPS_READ 0x0600 : #define IOBPS_WRITE 0x0700 : #define IOBPU 0x233a : #define IOBPU_MAGIC 0xf000
It's a copy of lynxpoint/pch.h.
Still, it would help w.r.t. readability.
https://review.coreboot.org/c/coreboot/+/41473/3/util/inteltool/iobp.c@90 PS3, Line 90: USBP01
Hmm, searched U2ECR and found https://medium. […]
Yes, it's the same as here: https://miro.medium.com/max/670/1*2iJaywnJdqjNeCJQSm-8kw.png