Rob Barnes has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/42832 )
Change subject: mb/google/zork: Add Bluetooth reset gpios to devicetree ......................................................................
Patch Set 13:
(2 comments)
https://review.coreboot.org/c/coreboot/+/42832/13/src/mainboard/google/zork/... File src/mainboard/google/zork/variants/baseboard/ramstage_common.c:
https://review.coreboot.org/c/coreboot/+/42832/13/src/mainboard/google/zork/... PS13, Line 115: xhci0_bt_cfg->reset_gpio.pin_count = 0;
This whole sequence could have used a helper function that took a path and string name as to not dup […]
I'll put up a CL.
https://review.coreboot.org/c/coreboot/+/42832/13/src/mainboard/google/zork/... PS13, Line 118: if (CONFIG(BOARD_GOOGLE_BASEBOARD_DALBOZ))
There is already a dalboz check below. This is redundant.
This is just defensive in case it's called by dalboz for whatever reason. We could remove it and change the name of the function to baseboard_trembyle_remove_bluetooth_reset_gpio.