Attention is currently required from: Jason Glenesk, Raul Rangel, Marshall Dawson, Fred Reitberger. Felix Held has uploaded this change for review. ( https://review.coreboot.org/c/coreboot/+/64128 )
Change subject: soc/amd/sabrina/fsp_m_params: add defines for FSP USB struct version ......................................................................
soc/amd/sabrina/fsp_m_params: add defines for FSP USB struct version
Add and use defines instead of magic values in fsp_m_params.c. The values will be updated to match the Sabrina FSP in a follow-up commit.
Signed-off-by: Felix Held felix-coreboot@felixheld.de Change-Id: I91da9e9d2b95e169dd73153766f24cf8afbfa4ef --- M src/soc/amd/sabrina/fsp_m_params.c M src/vendorcode/amd/fsp/sabrina/FspUsb.h 2 files changed, 5 insertions(+), 2 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/28/64128/1
diff --git a/src/soc/amd/sabrina/fsp_m_params.c b/src/soc/amd/sabrina/fsp_m_params.c index cf3278f..18de29a 100644 --- a/src/soc/amd/sabrina/fsp_m_params.c +++ b/src/soc/amd/sabrina/fsp_m_params.c @@ -143,8 +143,8 @@
if (config->usb_phy_custom) { mcfg->usb_phy = (struct usb_phy_config *)&config->usb_phy; - mcfg->usb_phy->Version_Major = 0xd; - mcfg->usb_phy->Version_Minor = 0x6; + mcfg->usb_phy->Version_Major = FSP_USB_STRUCT_MAJOR_VERSION; + mcfg->usb_phy->Version_Minor = FSP_USB_STRUCT_MINOR_VERSION; mcfg->usb_phy->TableLength = sizeof(usb_phy_config); } else { mcfg->usb_phy = NULL; diff --git a/src/vendorcode/amd/fsp/sabrina/FspUsb.h b/src/vendorcode/amd/fsp/sabrina/FspUsb.h index 6563cac..fea1fee 100644 --- a/src/vendorcode/amd/fsp/sabrina/FspUsb.h +++ b/src/vendorcode/amd/fsp/sabrina/FspUsb.h @@ -3,6 +3,9 @@
#include <FspUpd.h>
+#define FSP_USB_STRUCT_MAJOR_VERSION 0xd +#define FSP_USB_STRUCT_MINOR_VERSION 0x6 + #define USB2_PORT_COUNT 8 #define USB3_PORT_COUNT 4 #define USBC_COMBO_PHY_COUNT 2