Tim Wawrzynczak has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/39865 )
Change subject: soc/intel/tigerlake: Reorganize memory initialization support ......................................................................
Patch Set 3:
Patch Set 3:
Patch Set 3:
How about change all switch case to a marco? Like original code for DQS. All variable can just replace channel number.
I can do that and initially I had really liked it when the original code was done. But somehow looking back at it, it feels cryptic. If that is what feels better, I can definitely go back to it.
I'm the one that complained about the macros. I guess I'm just trying to push for not adding things like:
struct Bar { int Blah0; int Blah1; int Blah2; .... };
and just
struct Bar { int Blahs[TOTAL_BLAHS]; };
instead, because it makes everything easier to read and follow. The upstream Intel code is probably not going to change though, so maybe the macro does make it easier to read.