Attention is currently required from: Intel coreboot Reviewers, Jérémy Compostella, Patrick Rudolph, Paul Menzel, Shuo Liu.
Name of user not set #1005756 has posted comments on this change by Name of user not set #1005756. ( https://review.coreboot.org/c/coreboot/+/86562?usp=email )
Change subject: src/cpu/intel/car/romstage: Refactor stack guard code in romstage ......................................................................
Patch Set 5:
(5 comments)
Commit Message:
https://review.coreboot.org/c/coreboot/+/86562/comment/fc69adce_7885cc09?usp... : PS2, Line 7: src/cpu/intel/car/romstage.c
I suggest: cpu/intel/car/romstage
thank u for your opinion! 😊 Done.
https://review.coreboot.org/c/coreboot/+/86562/comment/33121651_9a6f94e7?usp... : PS2, Line 9: Refactor stack guard code in romstage.
Madybe more specific: Factor out stack_guard_set() and …() for improving readability.
thank u for your opinion! 😊 Done.
File src/cpu/intel/car/romstage.c:
https://review.coreboot.org/c/coreboot/+/86562/comment/efdcbbf0_893a3f33?usp... : PS3, Line 48: int i;
Shouldn't we use `size_t` for an iteration index variable ?
Thank u for your good opinion. Done
https://review.coreboot.org/c/coreboot/+/86562/comment/130419d3_e8ae9a00?usp... : PS3, Line 50: if (stack_base == NULL) {
How can `stack_base` be `NULL` ?
it seems that you're right. stack_base cannot be NULL. Delete this condition. thx. Done
https://review.coreboot.org/c/coreboot/+/86562/comment/d237bbea_824c44b5?usp... : PS3, Line 58: printk(BIOS_DEBUG, "Smashed stack detected in romstage!\n");
Is there a reason to keep executing the loop when an issue has been detected ?
Thank u for your effort to improve my commit! 😊
It's just original logic.(no 'break' when detect smashed stack.) In fact, I don't know why don't break exactly, So I just factor it out with it as is.
Is it fine that I add "break;" when smashed stack? Can i ask for you to give me good idea? if you have any opinions, I'll be glad to accept! Thx.