Angel Pons has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/38226 )
Change subject: device,sb/intel: Move SMBUS host controller prototypes ......................................................................
Patch Set 5: Code-Review+2
(3 comments)
https://review.coreboot.org/c/coreboot/+/38226/5/src/include/device/smbus_ho... File src/include/device/smbus_host.h:
https://review.coreboot.org/c/coreboot/+/38226/5/src/include/device/smbus_ho... PS5, Line 31: /* Only since ICH5 */ This comment is kind of odd now that it's outside `intel` scope
https://review.coreboot.org/c/coreboot/+/38226/5/src/southbridge/intel/commo... File src/southbridge/intel/common/smbus.c:
https://review.coreboot.org/c/coreboot/+/38226/5/src/southbridge/intel/commo... PS5, Line 336: smbus_base This name does not match that of the declaration in `smbus_host.h`
https://review.coreboot.org/c/coreboot/+/38226/5/src/southbridge/intel/commo... PS5, Line 383: int do_smbus_block_write(uintptr_t smbus_base, u8 device, u8 cmd, const size_t bytes, const u8 *buf)
line over 96 characters
Can fix this by using the same parameter names as in the declarations. However, for these functions, renaming is a bit more tedious.