Attention is currently required from: Hung-Te Lin, Rex-BC Chen, Paul Menzel, Angel Pons, Jianjun Wang. Yu-Ping Wu has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/63019 )
Change subject: soc/mediatek: Add mtk_early_init for passing data across sessions ......................................................................
Patch Set 4:
(5 comments)
File src/soc/mediatek/common/Kconfig:
https://review.coreboot.org/c/coreboot/+/63019/comment/5fa63a96_ea4132f6 PS1, Line 53: config MEDIATEK_EARLY_INIT : bool : help : This option allows passing data across sessions.
So can we keep it here?
hungte?
File src/soc/mediatek/common/early_init.c:
https://review.coreboot.org/c/coreboot/+/63019/comment/c74c4f18_4444edd6 PS4, Line 42: if (!init->saved_time[init_type].microseconds) shouldn't access microsecond field directly. Can we use memcmp?
https://review.coreboot.org/c/coreboot/+/63019/comment/203bed52_030bafd2 PS4, Line 45: timer_monotonic_get(&init->cur_time[init_type]); cur_time doesn't need to be in the struct. A local variable can be used.
File src/soc/mediatek/common/include/soc/early_init.h:
https://review.coreboot.org/c/coreboot/+/63019/comment/1623b153_6cec2594 PS4, Line 13: enum early_init_types { I'd prefer "type" without "s"
File src/soc/mediatek/common/include/soc/early_init.h:
https://review.coreboot.org/c/coreboot/+/63019/comment/acedf9bb_669c707f PS1, Line 10: mtk_early_init
Done
shouldn't we rename it to early_init_data?