Angel Pons has uploaded this change for review. ( https://review.coreboot.org/c/coreboot/+/48357 )
Change subject: soc/intel/common/hda_verb.c: Clarify mask usage ......................................................................
soc/intel/common/hda_verb.c: Clarify mask usage
The `azalia_set_bits` will mask out all bits, so just use zero for clarity. The resulting behavior is the same in both cases.
Change-Id: I27777f1e836fa973859629d48964060bec02c87a Signed-off-by: Angel Pons th3fanbus@gmail.com --- M src/soc/intel/common/hda_verb.c 1 file changed, 1 insertion(+), 1 deletion(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/57/48357/1
diff --git a/src/soc/intel/common/hda_verb.c b/src/soc/intel/common/hda_verb.c index ecf5a51..5a4b467 100644 --- a/src/soc/intel/common/hda_verb.c +++ b/src/soc/intel/common/hda_verb.c @@ -24,7 +24,7 @@ write8(base + HDA_STATESTS_REG, 0xf);
/* Turn off the link and poll RESET# bit until it reads back as 0 */ - if (azalia_set_bits(base + HDA_GCTL_REG, HDA_GCTL_CRST, ~HDA_GCTL_CRST) < 0) + if (azalia_set_bits(base + HDA_GCTL_REG, HDA_GCTL_CRST, 0) < 0) goto no_codec;
/* Turn on the link and poll RESET# bit until it reads back as 1 */