Arthur Heymans has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/38736 )
Change subject: lib/imd_cbmem.c: Add a helper function to indicate that cbmem is ready ......................................................................
Patch Set 4:
(2 comments)
https://review.coreboot.org/c/coreboot/+/38736/1/src/include/cbmem.h File src/include/cbmem.h:
https://review.coreboot.org/c/coreboot/+/38736/1/src/include/cbmem.h@84 PS1, Line 84: /* Returns 1 if cbmem is initialized, 0 otherwise */
Would probably make sense to make this a static inline and call cbmem_possibly_online() first, so that it allows for compile-time elimination in early stages. (For consistency it might also be better to call this cbmem_online().)
More or less done. Is static inline needed in the last implementation?
https://review.coreboot.org/c/coreboot/+/38736/1/src/include/cbmem.h@85 PS1, Line 85: int cbmem_ready(void);
Would probably be better to just set this either at the top or the bottom of cbmem_run_init_hooks()?
Done