Attention is currently required from: Kevin Chiu, Bhanu Prakash Maiya, Eric Peers, Karthik Ramasubramanian.
Rob Barnes has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/59051 )
Change subject: mb/google/guybrush/var/nipperkin: Update SPKR GPIO configuration
......................................................................
Patch Set 3:
(3 comments)
File src/mainboard/google/guybrush/variants/nipperkin/gpio.c:
https://review.coreboot.org/c/coreboot/+/59051/comment/bf19d5b6_ed865fcc
PS3, Line 39: /* EN_SPKR */
Should disconnect baseboard EN_SPKR / GPIO_31
https://review.coreboot.org/c/coreboot/+/59051/comment/4c683ad9_b6846e29
PS3, Line 40: PAD_GPO(GPIO_70, HIGH),
Should sdmode_gpio in nipperkin/overridetree.cb be GPIO_70?
https://review.coreboot.org/c/coreboot/+/59051/comment/eb74a8b6_60171b0f
PS3, Line 61: PAD_NC(GPIO_18),
GPIO_70 is disconnected in baseboard pcie_gpio_table. Should connect here.
--
To view, visit https://review.coreboot.org/c/coreboot/+/59051
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I3d82292b116f53d85d9518364ffd2169bd915a7e
Gerrit-Change-Number: 59051
Gerrit-PatchSet: 3
Gerrit-Owner: Kevin Chiu <kevin.chiu.17802(a)gmail.com>
Gerrit-Reviewer: Bhanu Prakash Maiya <bhanumaiya(a)google.com>
Gerrit-Reviewer: Eric Peers <epeers(a)google.com>
Gerrit-Reviewer: Karthik Ramasubramanian <kramasub(a)google.com>
Gerrit-Reviewer: Rob Barnes <robbarnes(a)google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Kevin Chiu <kevin.chiu.17802(a)gmail.com>
Gerrit-Attention: Bhanu Prakash Maiya <bhanumaiya(a)google.com>
Gerrit-Attention: Eric Peers <epeers(a)google.com>
Gerrit-Attention: Karthik Ramasubramanian <kramasub(a)google.com>
Gerrit-Comment-Date: Wed, 10 Nov 2021 16:06:22 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
Attention is currently required from: Sean Rhodes, Paul Menzel.
Hello build bot (Jenkins), Patrick Georgi,
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/coreboot/+/58343
to look at the new patch set (#20).
Change subject: ec/starlabs: Add standardised ITE EC support
......................................................................
ec/starlabs: Add standardised ITE EC support
Add EC support that supports different Q Events and EC memory.
Created from the ITE IT5570E and IT8987E datasheets, all using
data port 0x4e.
Tested with Ubuntu 20.04.3 and Windows 10 on:
* StarBook Mk V (TGL + IT5570E):
* ITE Firmware 1.00
* Merlin Firmware 1.00
* LabTop Mk IV (CML + IT8987E):
* ITE Firmware 1.04
* LabTop Mk III (KBL + IT8987E):
* ITE Firmware 3.12
Signed-off-by: Sean Rhodes <sean(a)starlabs.systems>
Change-Id: I8023c26de23c874c84106fda96e64dcfa0c5ba32
---
M 3rdparty/blobs
A src/ec/starlabs/merlin/Kconfig
A src/ec/starlabs/merlin/Makefile.inc
A src/ec/starlabs/merlin/acpi/ac.asl
A src/ec/starlabs/merlin/acpi/battery.asl
A src/ec/starlabs/merlin/acpi/cmos.asl
A src/ec/starlabs/merlin/acpi/ec.asl
A src/ec/starlabs/merlin/acpi/hid.asl
A src/ec/starlabs/merlin/acpi/keyboard.asl
A src/ec/starlabs/merlin/acpi/lid.asl
A src/ec/starlabs/merlin/acpi/suspend.asl
A src/ec/starlabs/merlin/acpi/typec.asl
A src/ec/starlabs/merlin/acpi/ubtc.asl
A src/ec/starlabs/merlin/ec.c
A src/ec/starlabs/merlin/ec.h
A src/ec/starlabs/merlin/variants/apl/ecdefs.h
A src/ec/starlabs/merlin/variants/apl/emem.asl
A src/ec/starlabs/merlin/variants/apl/events.asl
A src/ec/starlabs/merlin/variants/cml/ecdefs.h
A src/ec/starlabs/merlin/variants/cml/emem.asl
A src/ec/starlabs/merlin/variants/cml/events.asl
A src/ec/starlabs/merlin/variants/glk/ecdefs.h
A src/ec/starlabs/merlin/variants/glk/emem.asl
A src/ec/starlabs/merlin/variants/glk/events.asl
A src/ec/starlabs/merlin/variants/kbl/ecdefs.h
A src/ec/starlabs/merlin/variants/kbl/emem.asl
A src/ec/starlabs/merlin/variants/kbl/events.asl
A src/ec/starlabs/merlin/variants/merlin/ecdefs.h
A src/ec/starlabs/merlin/variants/merlin/emem.asl
A src/ec/starlabs/merlin/variants/merlin/events.asl
A src/ec/starlabs/merlin/variants/tgl/ecdefs.h
A src/ec/starlabs/merlin/variants/tgl/emem.asl
A src/ec/starlabs/merlin/variants/tgl/events.asl
33 files changed, 3,627 insertions(+), 1 deletion(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/43/58343/20
--
To view, visit https://review.coreboot.org/c/coreboot/+/58343
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I8023c26de23c874c84106fda96e64dcfa0c5ba32
Gerrit-Change-Number: 58343
Gerrit-PatchSet: 20
Gerrit-Owner: Sean Rhodes <admin(a)starlabs.systems>
Gerrit-Reviewer: Patrick Georgi <patrick(a)coreboot.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Sean Rhodes <admin(a)starlabs.systems>
Gerrit-Attention: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-MessageType: newpatchset
Kyösti Mälkki has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/58923 )
Change subject: ChromeOS: Fix <vc/google/chromeos/chromeos.h>
......................................................................
Patch Set 12:
(1 comment)
Commit Message:
https://review.coreboot.org/c/coreboot/+/58923/comment/e3caa84d_e97c90cd
PS12, Line 7: ChromeOS: Fix <vc/google/chromeos/chromeos.h>
> What does "fix" mean?
Here; one of spurious or missing include, for a lazy old dog too bothered to get interested about quick brown fox jumping all over.
--
To view, visit https://review.coreboot.org/c/coreboot/+/58923
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Ibbdd589119bbccd3516737c8ee9f90c4bef17c1e
Gerrit-Change-Number: 58923
Gerrit-PatchSet: 12
Gerrit-Owner: Kyösti Mälkki <kyosti.malkki(a)gmail.com>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Huang Jin <huang.jin(a)intel.com>
Gerrit-Reviewer: Julius Werner <jwerner(a)chromium.org>
Gerrit-Reviewer: Lee Leahy <leroy.p.leahy(a)intel.com>
Gerrit-Reviewer: Nick Vaccaro <nvaccaro(a)chromium.org>
Gerrit-Reviewer: Patrick Rudolph <siro(a)das-labor.org>
Gerrit-Reviewer: Tim Wawrzynczak <twawrzynczak(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Comment-Date: Wed, 10 Nov 2021 15:57:28 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-MessageType: comment
Attention is currently required from: Chris Wang, Karthik Ramasubramanian.
Rob Barnes has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/59092 )
Change subject: mb/google/guybrush/dewatt: update dewatt config
......................................................................
Patch Set 1: Code-Review+2
--
To view, visit https://review.coreboot.org/c/coreboot/+/59092
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Ide9e002390e59725dc0e45f83280db2a78270993
Gerrit-Change-Number: 59092
Gerrit-PatchSet: 1
Gerrit-Owner: Chris Wang <chris.wang(a)amd.corp-partner.google.com>
Gerrit-Reviewer: Karthik Ramasubramanian <kramasub(a)google.com>
Gerrit-Reviewer: Rob Barnes <robbarnes(a)google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Chris Wang <chris.wang(a)amd.corp-partner.google.com>
Gerrit-Attention: Karthik Ramasubramanian <kramasub(a)google.com>
Gerrit-Comment-Date: Wed, 10 Nov 2021 15:55:57 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment
Attention is currently required from: Kyösti Mälkki.
Angel Pons has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/58923 )
Change subject: ChromeOS: Fix <vc/google/chromeos/chromeos.h>
......................................................................
Patch Set 12:
(1 comment)
Commit Message:
https://review.coreboot.org/c/coreboot/+/58923/comment/c4ea46a8_b0eabeec
PS12, Line 7: ChromeOS: Fix <vc/google/chromeos/chromeos.h>
What does "fix" mean?
--
To view, visit https://review.coreboot.org/c/coreboot/+/58923
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Ibbdd589119bbccd3516737c8ee9f90c4bef17c1e
Gerrit-Change-Number: 58923
Gerrit-PatchSet: 12
Gerrit-Owner: Kyösti Mälkki <kyosti.malkki(a)gmail.com>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Huang Jin <huang.jin(a)intel.com>
Gerrit-Reviewer: Julius Werner <jwerner(a)chromium.org>
Gerrit-Reviewer: Lee Leahy <leroy.p.leahy(a)intel.com>
Gerrit-Reviewer: Nick Vaccaro <nvaccaro(a)chromium.org>
Gerrit-Reviewer: Patrick Rudolph <siro(a)das-labor.org>
Gerrit-Reviewer: Tim Wawrzynczak <twawrzynczak(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Kyösti Mälkki <kyosti.malkki(a)gmail.com>
Gerrit-Comment-Date: Wed, 10 Nov 2021 15:45:10 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
Attention is currently required from: Paul Menzel, Julius Werner.
Arthur Heymans has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/58934 )
Change subject: Documentation/coding_style.md: Avoid weakly linked symbols
......................................................................
Patch Set 2:
(1 comment)
Patchset:
PS2:
> Has there been some recent discussion about this somewhere that I may have missed? There's not a lot of context on this CL (commit message?) and it seems to go against practice that has been established in many parts of coreboot for years.
>
> I don't really agree with this at least in the form provided here -- I think weak functions are fine in the right context and cluttering Kconfig with a billion PLATFORM_USES_HOOK_XYZ isn't fundamentally a better alternative. We can discuss which situations are and aren't a good fit for weak symbols and then try to agree on some guidelines based on that, but I don't think a blanket "they're bad" is the right approach.
>
> Personally, I think weak functions are a good solution whenever generic code has a hook that can optionally be implemented by more specific (e.g. SoC or mainboard) code. Good examples for this are things like bootblock_soc_init(), bootblock_mainboard_init(), bootblock_mainboard_early_init(), etc... most platforms implement most of these functions, but sometimes not all of them. Hiding each of them behind a Kconfig and splattering every soc/.../Kconfig file with `select HAS_BOOTBLOCK_SOC_INIT`, `select HAS_BOOTBLOCK_SOC_EARLY_INIT`, etc. would just create a lot more config boilerplate (making it harder to read the meaningful options in between) and I don't think it would really help anyone's understanding of the code. The other alternative would be to add empty stub functions to each individual mainboard/SoC file when they're not using those hooks, but that's just adding more boilerplate there and I don't see how it would really make anything better either... also, it is a really annoying maintenance burden because whenever you need to add a new hook somewhere, you would have to add empty stubs to a billion SoC/mainboard files. I think weak functions solve this problem well and without causing any real issues... I mean, it's a hook, either you do something there or you don't, when you forgot to implement it then I guess your platform didn't need it anyway and the default weak no-op function was the right choice for you.
>
So I agree that optional mainboard specific hooks are not too bad. SOC specific weak override, I already like a lot less. The problem is that those weak functions are often used initially just to get things compile tested. In the end a real implementation is needed but forgotten because jenkins does not complain. A good example of this can be found in: https://review.coreboot.org/c/coreboot/+/58649 and https://review.coreboot.org/c/coreboot/+/58662/2. https://review.coreboot.org/c/coreboot/+/58657 was also needed, which pulled in a lot of NOP code due to the existence of weak functions.
> On the other hand, I do agree that weak functions can make things very confusing when the weak function actually implements meaningful behavior, and then overriding the function means you're missing that behavior. That's a terrible pattern that I think/hope we don't really use in coreboot anyway, and I think codifying that in the style guide would be fine. Weak functions should only be allowed when the weak implementation is a no-op or otherwise represents the most simple and "default" way the function could be implemented (and when that default implementation is generally "safe" from a security standpoint -- e.g. the weak implementation of vboot's get_recovery_mode_switch() is behind an extra Kconfig for a reason), but for those cases I think they can be an appropriate tool.
I don't think there are many cases of weak functions implementing actual meaningful behavior. There are however quite a few 'placeholders' weak functions that should have a meaningful implementation, but don't. Those placeholder functions sometimes even print to the console that an implementation is needed. This really pushes a problem from compiletime to runtime, and I'd like to stop that practice.
--
To view, visit https://review.coreboot.org/c/coreboot/+/58934
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: If70d38c5c646c1e8365bb16d3292cebb2787eba2
Gerrit-Change-Number: 58934
Gerrit-PatchSet: 2
Gerrit-Owner: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Reviewer: Julius Werner <jwerner(a)chromium.org>
Gerrit-Reviewer: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-CC: Hung-Te Lin <hungte(a)chromium.org>
Gerrit-CC: Nico Huber <nico.h(a)gmx.de>
Gerrit-Attention: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Julius Werner <jwerner(a)chromium.org>
Gerrit-Comment-Date: Wed, 10 Nov 2021 15:29:34 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Julius Werner <jwerner(a)chromium.org>
Gerrit-MessageType: comment
Attention is currently required from: Bao Zheng, Martin Roth, Marshall Dawson, Zheng Bao.
Felix Held has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/58764 )
Change subject: amdfwtool: Pack out-of-bounds check into a function and move
......................................................................
Patch Set 5: Code-Review+2
--
To view, visit https://review.coreboot.org/c/coreboot/+/58764
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I71117d1c817c0b6ddaea4ea47aea91672cc6d55a
Gerrit-Change-Number: 58764
Gerrit-PatchSet: 5
Gerrit-Owner: Bao Zheng <fishbaozi(a)gmail.com>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Reviewer: Marshall Dawson <marshalldawson3rd(a)gmail.com>
Gerrit-Reviewer: Martin Roth <martinroth(a)google.com>
Gerrit-Reviewer: Zheng Bao
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Patrick Georgi <patrick(a)coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Bao Zheng <fishbaozi(a)gmail.com>
Gerrit-Attention: Martin Roth <martinroth(a)google.com>
Gerrit-Attention: Marshall Dawson <marshalldawson3rd(a)gmail.com>
Gerrit-Attention: Zheng Bao
Gerrit-Comment-Date: Wed, 10 Nov 2021 15:27:11 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment
Attention is currently required from: YH Lin, Tim Wawrzynczak, Mark Hsieh, Felix Held, Zhuohao Lee.
Zhuohao Lee has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/59100 )
Change subject: mb/google/brya/var/gimble: Improve USB2 eye diagram of DB Type-C port
......................................................................
Patch Set 2: Code-Review+2
--
To view, visit https://review.coreboot.org/c/coreboot/+/59100
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Idcf13ad072ae5d7a897f54adb19e6b2b068609dc
Gerrit-Change-Number: 59100
Gerrit-PatchSet: 2
Gerrit-Owner: Mark Hsieh <mark_hsieh(a)wistron.corp-partner.google.com>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Mark Hsieh <mark_hsieh(a)wistron.corp-partner.google.com>
Gerrit-Reviewer: Tim Wawrzynczak <twawrzynczak(a)chromium.org>
Gerrit-Reviewer: YH Lin <yueherngl(a)google.com>
Gerrit-Reviewer: Zhuohao Lee <zhuohao(a)chromium.org>
Gerrit-Reviewer: Zhuohao Lee <zhuohao(a)google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Anfernee Chen <anfernee_chen(a)wistron.corp-partner.google.com>
Gerrit-CC: Ariel Fang <ariel_fang(a)wistron.corp-partner.google.com>
Gerrit-CC: Casper Chang <casper_chang(a)wistron.corp-partner.google.com>
Gerrit-CC: Malik Hsu <malik_hsu(a)wistron.corp-partner.google.com>
Gerrit-CC: Scott Chao <scott_chao(a)wistron.corp-partner.google.com>
Gerrit-CC: Terry Chen <terry_chen(a)wistron.corp-partner.google.com>
Gerrit-CC: Will Tsai <will_tsai(a)wistron.corp-partner.google.com>
Gerrit-Attention: YH Lin <yueherngl(a)google.com>
Gerrit-Attention: Tim Wawrzynczak <twawrzynczak(a)chromium.org>
Gerrit-Attention: Mark Hsieh <mark_hsieh(a)wistron.corp-partner.google.com>
Gerrit-Attention: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Attention: Zhuohao Lee <zhuohao(a)chromium.org>
Gerrit-Comment-Date: Wed, 10 Nov 2021 14:52:54 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment