Attention is currently required from: Christian Walter, Lean Sheng Tan, David Milosevic.
Angel Pons has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/68632 )
Change subject: mb/prodrive/atlas: add unique DIMM locators in smbios type17 ......................................................................
Patch Set 1: Code-Review+1
(3 comments)
File src/mainboard/prodrive/atlas/mainboard.c:
https://review.coreboot.org/c/coreboot/+/68632/comment/e4e5a148_f4576d73 PS1, Line 20: snprintf(dev_loc, sizeof(dev_loc), "DIMM-%d%d%d", mc, ch, mm); As per the SMBIOS spec, this should be the name of the slot as printed on the mainboard. If memory serves right, the slots are `SO-DIMM A0` and `SO-DIMM B0`. So, this should be:
snprintf(dev_loc, sizeof(dev_loc), "SO-DIMM %c%u", 'A' + mc, mm);
If you don't like the `'A' + mc` part, feel free to change it. But this would be the idea.
https://review.coreboot.org/c/coreboot/+/68632/comment/c5645d3f_a6cb40b1 PS1, Line 24: %d%d%d nit: use `%u` because unsigned. Also, maaaybe separate the numbers with hyphens or the like for clarity?
https://review.coreboot.org/c/coreboot/+/68632/comment/3a883e76_07ab95e4 PS1, Line 35: MC-%d-CH-%d-DIMM-%d nit: use `%u` because unsigned.