Attention is currently required from: Maximilian Brune, Nico Huber, Philipp Hug, ron minnich.
Julius Werner has posted comments on this change by Nico Huber. ( https://review.coreboot.org/c/coreboot/+/84087?usp=email )
Change subject: fit_payload: Use our region API ......................................................................
Patch Set 1: Code-Review+2
(2 comments)
Patchset:
PS1:
Copying from CB:79907 so it's not forgotten: […]
Hmm... I think it's not that bad? Maybe we should add `region_move()` and `region_resize()` helpers that basically do the same thing to make this sort of stuff more readable?
I think we can consider this trusted because it's loading executable code that we're about to jump to anyway, yeah. When calling this from `payload_load()` (only entry point we have for now, I think), it comes from CBFS and is covered by verification if enabled.
File src/arch/riscv/fit_payload.c:
https://review.coreboot.org/c/coreboot/+/84087/comment/679817a7_ddbe2bd3?usp... : PS1, Line 98: region_offset(kernel) + region_sz(kernel) Maybe we should still provide a `region_end()` helper (that's just `region_last() + 1`) for cases like this?