Attention is currently required from: Nicholas Sudsgaard, Paul Menzel.
Felix Held has posted comments on this change by Nicholas Sudsgaard. ( https://review.coreboot.org/c/coreboot/+/80332?usp=email )
The change is no longer submittable: All-Comments-Resolved is unsatisfied now.
Change subject: device/azalia: Separate codec checking and initialization ......................................................................
Patch Set 10:
(2 comments)
File src/device/azalia_device.c:
https://review.coreboot.org/c/coreboot/+/80332/comment/45443893_75c35505?usp... : PS10, Line 274: >= 0 i'd either use '== CB_SUCCESS' here or make codec_is_operative return a bool. i'd prefer the bool return type, since that's more what i'd expect from a function whose name contains 'is'
https://review.coreboot.org/c/coreboot/+/80332/comment/13d8a852_5635c113?usp... : PS10, Line 280: if (!codec_can_init(codec_mask, base, i)) : continue; : azalia_codec_init(base, i, cim_verb_data, cim_verb_data_size); i'd keep the logic as it was before and not do the inverse logic and a continue like it's done now.
if (codec_can_init(codec_mask, base, i)) azalia_codec_init(base, i, cim_verb_data, cim_verb_data_size);
at least to me that's easier to read