Attention is currently required from: Michał Żygowski.
Nicholas Sudsgaard has posted comments on this change by Michał Żygowski. ( https://review.coreboot.org/c/coreboot/+/83355?usp=email )
Change subject: superio/ite/common: Add common driver for GPIO and LED configuration ......................................................................
Patch Set 1:
(3 comments)
File src/superio/ite/common/gpio.c:
https://review.coreboot.org/c/coreboot/+/83355/comment/ea72be36_1657117d?usp... : PS1, Line 16: This ITE SIO GPIO driver support up to 10 GPIO sets "ITE SIO GPIO drivers only support up to 10 GPIO sets" sounds more natural as an error message.
File src/superio/ite/common/ite_gpio.h:
https://review.coreboot.org/c/coreboot/+/83355/comment/677e4c21_f2491b8b?usp... : PS1, Line 15: ITE_GPIO_PULLUP_DIS, : ITE_GPIO_PULLUP_EN To keep the naming consistent with the other enums. ```suggestion ITE_GPIO_PULLUP_DISABLE, ITE_GPIO_PULLUP_ENABLE ```
https://review.coreboot.org/c/coreboot/+/83355/comment/3f2300ff_47864a97?usp... : PS1, Line 63: ITE_LED_FREQ_2Hz_DUTY_50 = 3, : ITE_LED_FREQ_0P25HZ_DUTY_25 = 4, : ITE_LED_FREQ_0P25HZ_DUTY_75 = 5, : ITE_LED_FREQ_0P125HZ_DUTY_25 = 6, : ITE_LED_FREQ_0P125Hz_DUTY_75 = 7, : ITE_LED_FREQ_0P4Hz_DUTY_20 = 8, : ITE_LED_FREQ_0P5Hz_DUTY_50 = 16, : ITE_LED_FREQ_0P125Hz_DUTY_50 = 24, Is there a reason the 'z' is not capitalized for some of these enums? ```suggestion ITE_LED_FREQ_2HZ_DUTY_50 = 3, ITE_LED_FREQ_0P25HZ_DUTY_25 = 4, ITE_LED_FREQ_0P25HZ_DUTY_75 = 5, ITE_LED_FREQ_0P125HZ_DUTY_25 = 6, ITE_LED_FREQ_0P125HZ_DUTY_75 = 7, ITE_LED_FREQ_0P4HZ_DUTY_20 = 8, ITE_LED_FREQ_0P5HZ_DUTY_50 = 16, ITE_LED_FREQ_0P125HZ_DUTY_50 = 24, ```