Subrata Banik has submitted this change. ( https://review.coreboot.org/c/coreboot/+/84536?usp=email )
Change subject: mainboard/google/fatcat: Remove unused virtual GPIOs ......................................................................
mainboard/google/fatcat: Remove unused virtual GPIOs
This commit removes the virtual GPIOs for recovery and write protection from the fatcat variant.
These GPIOs are not utilized on the fatcat platform, and their removal simplifies the GPIO configuration and improves code readability.
The `CROS_GPIO_DEVICE_NAME` macro is no longer applicable for Panther Lake SoCs. Future changes will introduce a suitable GPIO device name that meets the requirements of Panther Lake.
BUG=b:347669091 TEST=Able to build google/fatcat.
Change-Id: I492fec28637edb2f84e9290b28dabce3f23aa867 Signed-off-by: Subrata Banik subratabanik@google.com Reviewed-on: https://review.coreboot.org/c/coreboot/+/84536 Reviewed-by: Pranava Y N pranavayn@google.com Tested-by: build bot (Jenkins) no-reply@coreboot.org --- M src/mainboard/google/fatcat/variants/fatcat/gpio.c 1 file changed, 0 insertions(+), 2 deletions(-)
Approvals: build bot (Jenkins): Verified Pranava Y N: Looks good to me, approved
diff --git a/src/mainboard/google/fatcat/variants/fatcat/gpio.c b/src/mainboard/google/fatcat/variants/fatcat/gpio.c index ebb0120..c966ab7 100644 --- a/src/mainboard/google/fatcat/variants/fatcat/gpio.c +++ b/src/mainboard/google/fatcat/variants/fatcat/gpio.c @@ -46,8 +46,6 @@ }
static const struct cros_gpio cros_gpios[] = { - CROS_GPIO_REC_AL(CROS_GPIO_VIRTUAL, CROS_GPIO_DEVICE_NAME), - CROS_GPIO_WP_AH(GPIO_PCH_WP, CROS_GPIO_DEVICE_NAME), };
DECLARE_CROS_GPIOS(cros_gpios);