Attention is currently required from: Hung-Te Lin, Yidi Lin, Yu-Ping Wu.
Jarried Lin has uploaded this change for review. ( https://review.coreboot.org/c/coreboot/+/85521?usp=email )
Change subject: soc/mediatek/mt8196: Rename SCP to SPM base variables ......................................................................
soc/mediatek/mt8196: Rename SCP to SPM base variables
Rename SCP_BASE to SPM_BASE and SCP_PBUS_BASE to SPM_PBUS_BASE.
TEST=build pass BUG=b:317009620
Change-Id: I044bdb5a02c7fef4cf7be1f6aa759a33d9cc0c8c Signed-off-by: Jarried Lin jarried.lin@mediatek.corp-partner.google.com --- M src/soc/mediatek/mt8196/include/soc/addressmap.h M src/soc/mediatek/mt8196/include/soc/pll.h 2 files changed, 3 insertions(+), 3 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/21/85521/1
diff --git a/src/soc/mediatek/mt8196/include/soc/addressmap.h b/src/soc/mediatek/mt8196/include/soc/addressmap.h index 6130e24..e4a4107 100644 --- a/src/soc/mediatek/mt8196/include/soc/addressmap.h +++ b/src/soc/mediatek/mt8196/include/soc/addressmap.h @@ -141,8 +141,8 @@ APINFRA_SSR_AO_DEBUG_BASE = IO_PHYS + 0x080F1000, AUDIO_BASE = IO_PHYS + 0x0A110000, VLPCFG_BASE = IO_PHYS + 0x0C001000, - SCP_BASE = IO_PHYS + 0x0C004000, - SCP_PBUS_BASE = IO_PHYS + 0x0C00D000, + SPM_BASE = IO_PHYS + 0x0C004000, + SPM_PBUS_BASE = IO_PHYS + 0x0C00D000, RGU_BASE = IO_PHYS + 0x0C010000, GPT_BASE = IO_PHYS + 0x0C015000, VLP_CKSYS_BASE = IO_PHYS + 0x0C016000, diff --git a/src/soc/mediatek/mt8196/include/soc/pll.h b/src/soc/mediatek/mt8196/include/soc/pll.h index 8f2854f..7995a65 100644 --- a/src/soc/mediatek/mt8196/include/soc/pll.h +++ b/src/soc/mediatek/mt8196/include/soc/pll.h @@ -36,7 +36,7 @@ static struct mtk_ssr_regs *const mtk_ssr = (void *)SSR_TOP_BASE; static struct mtk_spm_mtcmos_regs *const - mtk_spm_mtcmos = (void *)SCP_BASE; + mtk_spm_mtcmos = (void *)SPM_BASE; static struct mtk_vlp_regs *const mtk_vlpsys = (void *)VLP_CKSYS_BASE; static struct mtk_dispsys_regs *const