Attention is currently required from: Arthur Heymans, Anjaneya "Reddy" Chagam, Jonathan Zhang, Johnny Lin, Christian Walter, Angel Pons, TangYiwei.
Shuming Chu (Shuming) has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/68912 )
Change subject: soc/intel/xeon_sp: Don't sort struct device cpus for numa ......................................................................
Patch Set 4:
(7 comments)
Commit Message:
https://review.coreboot.org/c/coreboot/+/68912/comment/b5255799_3ec0981a PS3, Line 9: reassign
reassign*s*
Done
https://review.coreboot.org/c/coreboot/+/68912/comment/f513a9d1_01ce15f6 PS3, Line 12: break
break*s*
Done
https://review.coreboot.org/c/coreboot/+/68912/comment/9672c376_cf06bd79 PS3, Line 15: This moves the sorting to of the lapic_ids to the srat table generation
Yes, the `to` is spurious
Done
File src/soc/intel/xeon_sp/cpx/cpu.c:
https://review.coreboot.org/c/coreboot/+/68912/comment/c90902e6_10320c8a PS3, Line 81: apic_id
Should be package_id
I don't see any place update package_id and the bottom layer uses apic_id to get package information so I suppose keep using apic_id?
File src/soc/intel/xeon_sp/include/soc/util.h:
https://review.coreboot.org/c/coreboot/+/68912/comment/92216128_9c7d5308 PS3, Line 15: uint8_t get_cpu_package(const uint32_t apic_id);
Should we name it get_cpu_socket()?
This function uses apic_id to get package information and the bottom layer uses the name "package", maybe keep the name here?
File src/soc/intel/xeon_sp/nb_acpi.c:
https://review.coreboot.org/c/coreboot/+/68912/comment/705f46aa_613a108b PS3, Line 41: if (num_cpus > 1)
We don't need these checks, bubblesort bails out early if there's less than 2 elements to sort.
Remove the checker.
File src/soc/intel/xeon_sp/util.c:
https://review.coreboot.org/c/coreboot/+/68912/comment/70666811_47c8415d PS3, Line 161: uint8_t get_cpu_package(const uint32_t apic_id)
Could we add some comments here? Such as what it means by a "package" in this context?
Done