Attention is currently required from: Hung-Te Lin, Jarried Lin, Yidi Lin, Yu-Ping Wu.
Hope Wang has posted comments on this change by Jarried Lin. ( https://review.coreboot.org/c/coreboot/+/85630?usp=email )
Change subject: soc/mediatek/mt8196: Add PMIC MT6316 driver ......................................................................
Patch Set 10:
(10 comments)
File src/soc/mediatek/common/mt6316.c:
https://review.coreboot.org/c/coreboot/+/85630/comment/e888507d_d664747d?usp... : PS9, Line 20: read16
This should be `read` (which is for reading 1 byte). `read16` is for reading 2 bytes. […]
Done
https://review.coreboot.org/c/coreboot/+/85630/comment/37b92c1e_5d5d5b21?usp... : PS9, Line 59: 0x%x
%#x
Done
https://review.coreboot.org/c/coreboot/+/85630/comment/81182c04_91fbce1b?usp... : PS9, Line 86: 0x%x
%#x
Done
https://review.coreboot.org/c/coreboot/+/85630/comment/9d7a0274_8dc16882?usp... : PS9, Line 113: 0x%x
%#x
Done
https://review.coreboot.org/c/coreboot/+/85630/comment/6bc8acd2_cfbae025?usp... : PS9, Line 114: vol * 5000 + vol_l * 2500
Use a local variable to to store this.
Done
https://review.coreboot.org/c/coreboot/+/85630/comment/a59494d0_6476fa91?usp... : PS9, Line 118: mode
Does this mean enable/disable? Can we rename this to `enable`?
Done
https://review.coreboot.org/c/coreboot/+/85630/comment/73b99860_d9266bce?usp... : PS9, Line 161: mod = mt6316_read8(slvid, MT6316_BUCK_TOP_4PHASE_TOP_ANA_CON0); : mod >>= mod_shift; : mod &= 0x1;
Isn't this `mod = mt6316_read_field(slvid, MT6316_BUCK_TOP_4PHASE_TOP_ANA_CON0, 0x1, mod_shift)`?
Done
https://review.coreboot.org/c/coreboot/+/85630/comment/efc0a46d_ba89e7c4?usp... : PS9, Line 164: d
%u ?
Done
https://review.coreboot.org/c/coreboot/+/85630/comment/bead7cce_f0df8766?usp... : PS9, Line 165: mod ? true : false
`!!mod`
Done
https://review.coreboot.org/c/coreboot/+/85630/comment/ad3163cb_c20016a2?usp... : PS9, Line 186: mt6316_slave_id[i], mt6316_read_field(mt6316_slave_id[i], : MT6316_PMIC_SWCID_H_ADDR, 0xFF, 0x0));
Done