Attention is currently required from: Nico Huber, Maximilian Brune, Arthur Heymans.
Julius Werner has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/68160 )
Change subject: util/cbfstool: Add a new mechanism to provide a memory mapped ......................................................................
Patch Set 3:
(4 comments)
File src/soc/intel/common/block/fast_spi/Makefile.inc:
https://review.coreboot.org/c/coreboot/+/68160/comment/fdbebbf7_d934b25b PS3, Line 91: $(call int-subtract, $(CONFIG_ROM_SIZE) 0x1000000) Can we factor this term out into a separate variable (e.g. ext_rom_size or something like that)? I think that would make this easier to read.
File util/cbfstool/cbfstool.c:
https://review.coreboot.org/c/coreboot/+/68160/comment/97cdcc45_f4becb8a PS3, Line 317: static int next_window; nit: namespace a bit better since it's a global (e.g. mmap_next_window)
https://review.coreboot.org/c/coreboot/+/68160/comment/41d6bfd0_c4ee0141 PS3, Line 338: MMAP_SIZE nit: That's a bit of an odd way to name fields in an array, particularly since these constants are global and not very well namespaced. How about this instead? ``` union { unsigned long int array[3]; struct { unsigned long int flash_base; unsigned long int mmap_base; unsigned long int mmap_size; }; } mmap_args; ```
https://review.coreboot.org/c/coreboot/+/68160/comment/8b5af9cb_428c45df PS3, Line 358: optarg); Note that this will no longer print the full argument because strtok() cuts it into pieces in-place. Not sure if we care.