Felix Held has uploaded this change for review. ( https://review.coreboot.org/c/coreboot/+/33633
Change subject: device/pci_rom: use ALIGN_UP instead of ALIGN for better readability ......................................................................
device/pci_rom: use ALIGN_UP instead of ALIGN for better readability
Change-Id: Icb0b3fd22fa9b6ea73b7770079f81335e40fd0d3 Signed-off-by: Felix Held felix-coreboot@felixheld.de --- M src/device/pci_rom.c 1 file changed, 1 insertion(+), 1 deletion(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/33/33633/1
diff --git a/src/device/pci_rom.c b/src/device/pci_rom.c index 2dbfb51..3160c20 100644 --- a/src/device/pci_rom.c +++ b/src/device/pci_rom.c @@ -257,7 +257,7 @@
/* AMD/ATI uses VFCT */ if (device->vendor == PCI_VENDOR_ID_ATI) { - current = ALIGN(current, 8); + current = ALIGN_UP(current, 8); printk(BIOS_DEBUG, "ACPI: * VFCT at %lx\n", current); vfct = (struct acpi_vfct *)current; acpi_create_vfct(device, vfct, pci_rom_acpi_fill_vfct);