Attention is currently required from: Jason Glenesk, Raul Rangel, Anjaneya "Reddy" Chagam, Marshall Dawson, Jonathan Zhang, Johnny Lin, Paul Menzel, Angel Pons, Arthur Heymans, Morgan Jang, Patrick Rudolph. Felix Held has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/55063 )
Change subject: src: Use initial_lapicid() instead of open coding it ......................................................................
Patch Set 3:
(8 comments)
Commit Message:
https://review.coreboot.org/c/coreboot/+/55063/comment/418920e6_edac94ed PS1, Line 7: use
I'd also add a prefix: […]
Done
https://review.coreboot.org/c/coreboot/+/55063/comment/aa0141f8_6fbc6968 PS1, Line 7: opencoding
I believe `open coding` is spelled with a space
Done
File src/drivers/amd/agesa/eventlog.c:
https://review.coreboot.org/c/coreboot/+/55063/comment/6ae72f3a_be797144 PS1, Line 101: task->apic_id = (u8)initial_lapicid();
Would this work in x2APIC mode?
hm, good question. does the old agesa code support x2apic anyway?
File src/drivers/amd/agesa/romstage.c:
https://review.coreboot.org/c/coreboot/+/55063/comment/1bcdd957_3da08726 PS1, Line 39: u32
`unsigned int`
Done
File src/soc/amd/picasso/mca.c:
https://review.coreboot.org/c/coreboot/+/55063/comment/8d8afdbd_7143b7be PS2, Line 167: int
See my comments on earlier patchsets. […]
Done
File src/soc/amd/stoneyridge/mca.c:
https://review.coreboot.org/c/coreboot/+/55063/comment/d05e81f2_0c9e69f8 PS1, Line 169: uint32_t
`initial_lapicid()` returns `unsigned int`. […]
Done
https://review.coreboot.org/c/coreboot/+/55063/comment/198b744f_40634fea PS1, Line 171: %d
Needs to be changed to `%u` now that `core` is of unsigned type. […]
Done
File src/soc/intel/xeon_sp/smmrelocate.c:
https://review.coreboot.org/c/coreboot/+/55063/comment/e4ccd59a_39060418 PS1, Line 90: int apic_id;
This can be removed now.
Done