Shelley Chen has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/46432 )
Change subject: security/vboot: Make mrc_cache hash functions generic ......................................................................
Patch Set 2:
(6 comments)
https://review.coreboot.org/c/coreboot/+/46432/1/src/security/vboot/antiroll... File src/security/vboot/antirollback.h:
https://review.coreboot.org/c/coreboot/+/46432/1/src/security/vboot/antiroll... PS1, Line 27: NORM_HASH_NV_INDEX
I'd call this MRC_HASH_NV_INDEX (or something like MRC_RW_HASH_NV_INDEX if you want to be specific) […]
Done
https://review.coreboot.org/c/coreboot/+/46432/1/src/security/vboot/mrc_cach... File src/security/vboot/mrc_cache_hash_tpm.c:
https://review.coreboot.org/c/coreboot/+/46432/1/src/security/vboot/mrc_cach... PS1, Line 57: printk(BIOS_INFO, "MRC: TPM MRC hash updated successfully.\n");
nit: might be nice to also print the index here now
Done.
https://review.coreboot.org/c/coreboot/+/46432/1/src/security/vboot/mrc_cach... PS1, Line 93: "Using data from MRC_CACHE\n");
nit: here too (and I'm not sure what "Using data from MRC_CACHE" is really supposed to tell us here, […]
Done.
https://review.coreboot.org/c/coreboot/+/46432/1/src/security/vboot/secdata_... File src/security/vboot/secdata_tpm.c:
https://review.coreboot.org/c/coreboot/+/46432/1/src/security/vboot/secdata_... PS1, Line 420: uint32_t antirollback_read_space_hash(uint32_t index, uint8_t *data, uint32_t size)
BTW there are stub versions of these functions in secdata_mock.c that you need to update as well.
Done
https://review.coreboot.org/c/coreboot/+/46432/1/src/security/vboot/secdata_... PS1, Line 423: rec
nit: remove
Done
https://review.coreboot.org/c/coreboot/+/46432/1/src/security/vboot/secdata_... PS1, Line 437: rec
here too
Done