Felix Held has uploaded this change for review. ( https://review.coreboot.org/c/coreboot/+/33631
Change subject: arch/arm/cpu: use ALIGN_UP instead of ALIGN for better readability ......................................................................
arch/arm/cpu: use ALIGN_UP instead of ALIGN for better readability
Change-Id: Id0e281ece0a647721c18402029cd6980f75d5908 Signed-off-by: Felix Held felix-coreboot@felixheld.de --- M src/arch/arm/cpu.c 1 file changed, 1 insertion(+), 1 deletion(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/31/33631/1
diff --git a/src/arch/arm/cpu.c b/src/arch/arm/cpu.c index fae1a37..93d5675 100644 --- a/src/arch/arm/cpu.c +++ b/src/arch/arm/cpu.c @@ -39,7 +39,7 @@ "feature, make sure you add the proper assertions " \ "(and maybe consider revising the whole thing to work closer to what " \ "arm64 is doing now)." - uintptr_t addr = ALIGN((uintptr_t)__builtin_frame_address(0), + uintptr_t addr = ALIGN_UP((uintptr_t)__builtin_frame_address(0), CONFIG_STACK_SIZE); addr -= sizeof(struct cpu_info); return (void *)addr;