Attention is currently required from: Christian Walter, Julius Werner, Jett Rink. Jes Klinke has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/63158 )
Change subject: tpm: Accept Google Ti50 TPM DID:VID ......................................................................
Patch Set 1:
(1 comment)
File src/drivers/spi/tpm/tpm.c:
https://review.coreboot.org/c/coreboot/+/63158/comment/c940e83e_814645a4 PS1, Line 515: if (tpm_first_access_this_boot()) { : /* This is called for the side-effect of printing the firmware version : string */ : cr50_get_firmware_version(&ver); : }
This is in a ti50 only block, and I would have expected this code to be in a cr50 only block
Cr50 and Ti50 share the same 3-item version number format, so I could rename `struct cr50_firmware_version` into `struct gsc_firmware_version`. And then either rename the `cr50_get_firmware_version()` into `gsc_get_firmware_version()`, or maintain separate cr50_ and ti50_ methods for retrieving, parsing and printing version numbers.
What do you think?